Convert more CSS filters to WebRender display items

RESOLVED FIXED in Firefox 55

Status

()

RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: mrobinson, Assigned: mrobinson)

Tracking

(Blocks: 1 bug)

Trunk
mozilla55
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox55 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

Now that WebRender is enabled for a few filters, we should enable the ones that only introduce <1 pixel differences in reference tests.
Blocks: 1351131
Depends on: 1365972
Blur is the most commonly used filter so it be nice to get that one done first.
Even if we can't turn blur on by default it would be good to have the code in place so that we can do some rough performance testing.
I wasn't going to enable blur in this bug, bug I've opened https://bugzilla.mozilla.org/show_bug.cgi?id=1370564 to track this. I should be able to get a patch for rudimentary performance testing fairly easily.
Created attachment 8875185 [details] [diff] [review]
Convert more CSS filters to WebRender display items

Activate WebRender output for filters that introduce only one pixel
differences in tests. Since the filters spec does not seem to specify
how color values are rounded, this output should be spec compliant.
Attachment #8875185 - Flags: review?(rhunt)
Attachment #8875185 - Flags: review?(rhunt)
Created attachment 8875237 [details] [diff] [review]
Convert more CSS filters to WebRender display items

Activate WebRender output for filters that introduce only one pixel
differences in tests. Since the filters spec does not seem to specify
how color values are rounded, this output should be spec compliant.
Attachment #8875185 - Attachment is obsolete: true
Comment on attachment 8875237 [details] [diff] [review]
Convert more CSS filters to WebRender display items

Here is the try run for this patch: https://treeherder.mozilla.org/#/jobs?repo=try&revision=4729bdddd864fa5fecea7f918e59c96c5d80b59d&selectedJob=105143389
Attachment #8875237 - Flags: review?(rhunt)
Attachment #8875237 - Flags: review?(rhunt) → review+
Keywords: checkin-needed
Assignee: nobody → mrobinson

Comment 7

2 years ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0048424c784a
Convert more CSS filters to WebRender display items. r=jrmuizel
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/0048424c784a
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
status-firefox55: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla55
You need to log in before you can comment on or make changes to this bug.