Hover state not always updated

VERIFIED DUPLICATE of bug 137067

Status

()

Core
Layout
P3
normal
VERIFIED DUPLICATE of bug 137067
16 years ago
16 years ago

People

(Reporter: Alfred Kayser, Assigned: Marc Attinasi)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
The hover state of elements is not always updated.
This is happening since build 2002041103 (Win95).

How to reproduce:
1. Use the 'LittleMozilla' theme, click on a 'folder' button
   on the Personal Toolbar, and click on a bookmark in the menu.
   The page starts to load but the menubuttons keeps the hover state.

2. Move the mouse over the menubar, and notice how the hover state
   remains even if mouse is not hovering the item...
   Only by opening an menu and then using the arrows keys
   will remove the hover state.

Note: this is probably related to the hover/underline/link bugs solved
yesterday. 
Note: While I refer to LittleMozilla, the hover state is not dependend on the
used theme. LittleMozilla only shows the problem in more detail.

Comment 1

16 years ago
I do not know if this has anything to do with this, but the drop down buttons
(beside back/forward and print) do not return to the non-hover state in modern.

Comment 2

16 years ago
drop-down buttons hover state stuck is bug 137124

Comment 3

16 years ago
This may be the same underlying problem as bug 137124, bug 137247, even bug
137067 could come out similar or even the same.

I'm seeing this in my development version of EarlyBlue as well. In this skin,
toolbarbuttons should react in a way similar to classic (showing without borders
normally, showing an outset border on mouseover), however, often they don't show
any :hover effect, and if they are clicked, they don't lose the :hover border
when mouse goes off...

I'll try to get a reduced testcase - but that's more difficult now that we don't
have dynamic skin switching :(

Comment 4

16 years ago
BTW, perhaps all those bugs should be assigned to dbaron, who fixed bug 5693 and
is knowing very much of how :hover is working now...

Comment 5

16 years ago
Hmm this seems to be some strange problem, but I start to think that it's not a
problem of :hover itself but of the skins.

When I inserted
@import url("chrome://global/skin/toolbarbutton.css");
into global/global.css in my skin while testing, the toolbarbuttons started
working right!

When inserting
@import url("chrome://global/skin/button.css");
into the same file, bug 137067 goes away as well...

So it seems for me that somehow those files' contents aren't picked up like they
should - or they're overridden somewhere - I just couldn't figure out where :(
This is probably a duplicate of bug 137067.

Comment 7

16 years ago
Changing QA contact
QA Contact: petersen → moied

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Priority: -- → P3

Comment 8

16 years ago
alfred, this looks fixed to me with 137067 fixed.
I'll mark it as a dupe of that for dbaron's comment and what I'm seeing. Reopen
it when you see 137067 fixed but this one unfixed.

*** This bug has been marked as a duplicate of 137067 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 9

16 years ago
Confirm fixed, as in builds started from 2002041603 (and may be earlier).
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.