Wrong date&time format in en-US SeaMonkey and German Win7

RESOLVED DUPLICATE of bug 1366134

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 1366134
4 months ago
4 months ago

People

(Reporter: chokito, Unassigned)

Tracking

SeaMonkey 2.50 Branch

SeaMonkey Tracking Flags

(seamonkey2.50 affected, seamonkey2.51 affected, seamonkey2.52 affected, seamonkey2.53 affected)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 months ago
Created attachment 8875785 [details]
image.png

User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:52.0) Gecko/20100101 Firefox/52.0 SeaMonkey/2.49.1
Build ID: 20170528045907

Steps to reproduce:

Until now the date&time in an en-US SeaMonkey under German Win7 shows localized values.


Actual results:

See picture SM2.52a1-20170608.png ...


Expected results:

See picture SM2.49.1esr-20170528.png ...

Comment 1

4 months ago
Probably DUP of "Bug 1355565 - pref mail.ui.display.dateformat.default ignores system date format", which has become DUP of "Bug 1344594 - System date and time formats are not respected (all platforms) "

@chokito:
Your opinion?
Flags: needinfo?(chokito)
(Reporter)

Comment 2

4 months ago
Yes, it would be possible.
Flags: needinfo?(chokito)

Comment 3

4 months ago
Bug 1344594 is fixed, I wonder whether we should leave open a SM Bug for Tracking the pulll of the TB fix to SM.
See Also: → bug 1344594
Well fixed is relative...  From what I read I consider the underlying apis Mozilla provides still broken and this is the expected behaviour with a en-US version and German OS. They do not honor the OS settings.

Jorg, did TB itself need an update outside of the mailnews part which we need to port?
Flags: needinfo?(jorgk)

Comment 5

4 months ago
This is a complicated issue.

First we need to distinguish C++ formatted dates (like in the thread pane) and JS formatted dates, like in many other spots in the application and in the Calendar add-on.

C++ dates are fixed by bug 1351427 (I fixed that myself). So now an en-US version of the software will respect regional settings for any en-* locale, so if you switch to en-GB you get dd/mm/yyyy for example.

C++ dates *will not* respect regional setting for any other language, so en-US software will show en-US formats if the regional settings are de or de-DE or de-AT. That's what you can see in attachment 8875785 [details]. Mozilla is pretty firm on this, but there is an ongoing discussion in bug 1366134.

JS dates can use various underlying interfaces:
Intl.DateTimeFormat/ECMA402/toLocaleDateString
                        - Part of the JS standard, but should be replaced with
                          mozIMozIntl for chrome dates.
nsIScriptableDateFormat - To be phased out completely.
mozIMozIntl             - New method to use for chrome dates.

In the end, all chrome dates need to be moved to mozIMozIntl and we have the following open bugs to do so:
Bug 1346549 - mail
Bug 1313659 - editor, chat
Bug 1356403 - mozIntl - Chrome dates
Bug 1360915 - MozIntl, calendar

Once those four bugs are done, JS dates should behave like C++ dates.
Flags: needinfo?(jorgk)
Thanks. Will open a new bug for mozIntl suite. I suspect this here will be wontfix or a duplicate of bug 1366134.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 months ago
Depends on: 1376167
Resolution: --- → DUPLICATE
Duplicate of bug: 1366134
status-seamonkey2.50: --- → affected
status-seamonkey2.51: --- → affected
status-seamonkey2.52: --- → affected
status-seamonkey2.53: --- → affected
Version: SeaMonkey 2.52 Branch → SeaMonkey 2.50 Branch

Comment 8

4 months ago
> seamonkey2.50: --- -> affected
Probably not. SeaMonkey 2.50 en_US (Build ID 20170528012211) on German Windows 10 1607 shows localized date/time format in mail views.

> seamonkey2.51: --- -> affected
Yes.
You need to log in before you can comment on or make changes to this bug.