Closed Bug 1371531 Opened 2 years ago Closed 2 years ago

Should add the Single search tour in the onBoarding overlay

Categories

(Firefox :: General, enhancement, P1)

enhancement

Tracking

()

VERIFIED FIXED
Firefox 57
Tracking Status
firefox56 --- verified

People

(Reporter: rexboy, Assigned: rexboy)

References

Details

(Whiteboard: [photon-onboarding] )

Attachments

(3 files)

Should add the Single search location tour in the onBoarding overlay.

aims for version 57, on updated user.
Screenshots (page actions)
Summary: Should add the screenshot tour in the onBoarding overlay → Should add the Single search tour in the onBoarding overlay
my bad, please ignore comment 1.
Flags: qe-verify+
QA Contact: jwilliams
Target Milestone: --- → Firefox 56
Target Milestone: Firefox 56 → Firefox 57
Blocks: 1354046
No longer blocks: 1356479
No longer depends on: 1357046
Duplicate of this bug: 1371541
Blocks: 1367698
No longer blocks: 1354046
Assignee: nobody → rexboy
Attached image Mockup
We don't have visual assets yet, so I just made some mockup based on the result of searching "Firefox" given in bug 1371542.

The patch will be ready after we have visual assets and texts.
Even if it's not final:
* Don't hard code the browser name in strings.
* You have a double space after a comma.
Seems we're going to use the same assets with search tour.
I'm preparing the patch.

(In reply to Francesco Lodolo [:flod] from comment #6)
> Even if it's not final:
> * Don't hard code the browser name in strings.
> * You have a double space after a comma.
Wow! Thanks for the early reminding Flod!
The patch is ready. Mossop and Flod would you take a look?

This tour is not going to be shown until version 57. To reveal the tour, please change the pref:
browser.onboarding.newtour=private,addons,customize,singlesearch,default
browser.onboarding.mute-duration-on-first-session-ms=0
...and this pref for showing Notification.
browser.onboarding.notification.tour-ids-queue=onboarding-tour-singlesearch,onboarding-tour-default-browser,onboarding-tour-sync,onboarding-tour-addons,onboarding-tour-default-browser,onboarding-tour-sync
Comment on attachment 8886982 [details]
Bug 1371531 - Add single search tour and notification to onboarding.

https://reviewboard.mozilla.org/r/157738/#review163450

::: browser/extensions/onboarding/bootstrap.js:34
(Diff revision 2)
>  [
>    "onboarding-tour-private-browsing",
>    "onboarding-tour-addons",
>    "onboarding-tour-customize",
>    "onboarding-tour-search",
> +  "onboarding-tour-singlesearch",

we could put new id in alphabet

::: browser/extensions/onboarding/content/onboarding-tour-agent.js:33
(Diff revision 2)
>        let emailInput = document.getElementById("onboarding-tour-sync-email-input");
>        if (emailInput.checkValidity()) {
>          Mozilla.UITour.showFirefoxAccounts(null, emailInput.value);
>        }
>        break;
> +    case "onboarding-tour-singlesearch-button":

we can put new switch case in alphabet

::: browser/extensions/onboarding/content/onboarding.js:241
(Diff revision 2)
> +        <section class="onboarding-tour-description">
> +          <h1 data-l10n-id="onboarding.tour-singlesearch.title"></h1>
> +          <p data-l10n-id="onboarding.tour-singlesearch.description"></p>
> +        </section>
> +        <section class="onboarding-tour-content">
> +          <img src="resource://onboarding/img/figure_search.svg" />

need add `role="presentation"` for accessibility
Comment on attachment 8886982 [details]
Bug 1371531 - Add single search tour and notification to onboarding.

https://reviewboard.mozilla.org/r/157738/#review162836

No issues on my side. At risk of stating the obvious, I'm only looking at the l10n bits, not at the code part.
Attachment #8886982 - Flags: review?(francesco.lodolo) → review+
Priority: P2 → P1
Comment on attachment 8886982 [details]
Bug 1371531 - Add single search tour and notification to onboarding.

https://reviewboard.mozilla.org/r/157738/#review164370
Attachment #8886982 - Flags: review?(dtownsend) → review+
Duplicate of this bug: 1371534
Status: NEW → ASSIGNED
need rebase.
Keywords: checkin-needed
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/327ab3867919
Add single search tour and notification to onboarding. r=flod,mossop
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/327ab3867919
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
I can see Single search location tour as Address Bar and  showing Notification in  onboarding overlay after changing pref as per comment 9 and comment 11 on latest nightly in  Ubuntu 16.04(64 Bit).

Build ID   : 20170722112649

User Agent : Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170719]
Changing pref as per comment 9 and comment 11 ,I can see Single search location tour as Address Bar and  showing Notification in  onboarding on latest nightly 56.0a1 (2017-07-25) (32-bit) in windows 10(32 bit)

Build ID   :20170725030209

Mozilla/5.0 (Windows NT 10.0; rv:56.0) Gecko/20100101 Firefox/56.0
QA Whiteboard: [bugday-20170719] → [bugday-20170726]
As per Comment 23 and Comment 24, I am marking this bug as verified fixed
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.