Last Comment Bug 137164 - RDF horkage when sharing profile between Netscape and Mozilla
: RDF horkage when sharing profile between Netscape and Mozilla
Status: RESOLVED WONTFIX
: relnote
Product: Core
Classification: Components
Component: Preferences: Backend (show other bugs)
: Trunk
: All All
: -- normal with 5 votes (vote)
: Future
Assigned To: preferences
: Nobody; OK to take it and work on it
: Benjamin Smedberg [:bsmedberg]
Mentors:
Depends on:
Blocks: profile-corrupt
  Show dependency treegraph
 
Reported: 2002-04-12 12:42 PDT by Claudius Gayle
Modified: 2006-03-27 14:08 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Claudius Gayle 2002-04-12 12:42:11 PDT
This bug description isn't fully developed yet but I needed to get it into the
system so I can get a bug# and release note it.

On 3 separate occasions (bug#'s forthcoming) I have seen profile sharing be the
root cause of some problem that boils down to the rdf datasource having been
damaged. The most notable of these is the 'B.U.S.' (Bookmarks of Unbelieveable
Size) bug.
Comment 1 Claudius Gayle 2002-04-12 13:58:10 PDT
bug 127856 appears to be the worst consequence, comment 17 is the most informative.
bugscape bugs 11537 and 11547 seem to be a result of profile sharing as well.
The common thread is that all rely on an rdf datasource.
Comment 2 Chris Waterson 2002-04-15 13:27:06 PDT
Um, yeah. Don't do that.
Comment 3 Claudius Gayle 2002-04-19 12:59:46 PDT
repeating the summary because I hate when it's not in the body of a bug:
"Sharing the same profile with NS +Moz seems to cause RDF horkage"
An action intrinsically supported by our Profile Manager which recognizes them
as twin equals.


If you point someone to a door with 'Enter' on it and the handle shocks them
when they touch it - maybe they shouldn't do that, but that still makes you a
pretty mean bastard.

that is to say...
If Netscape can't use a Mozilla profile(and vice-versa) without causing nasty
corruption then it shouldn't be trying. We should offer to import and create a
new one without harming the old one - just like we do with other browsers that
we like/share users with/ and support but with which we have incompatible
profiles. (uhh 4.x)

Believe me, I'm overjoyed to mark bugs that stem from this behavior as invalid
(and I will) but that doesn't strike at the core issue. Lots of users, QA, and
developers have spent a ton of time chasing down these demons - no one knew of
this incompatibility. Isn't there something to be done?
Comment 4 Adam Katz 2002-04-25 15:15:09 PDT
bug 139926 may be related.  it deals with sharing moz+moz (migration actually).
Comment 5 lchiang 2002-05-03 18:15:03 PDT
I believe http://bugzilla.mozilla.org/show_bug.cgi?id=76431 will cover this in
some respect.
Comment 6 Andrew Hagen 2002-06-05 10:56:48 PDT
Bug 76431 covered multiple instances of Mozilla running concurrently. This bug
covers different instances of Mozilla and Netscape using the same profile
nonconcurrently. This bug is related to bug 131014 and bug 134517.

The 1.0 relnote for this bug is good but not enough. The solution should be that
Netscape creates its own registry.dat and doesn't touch Mozilla's. That should
be done for the next major Netscape release, or there will be a lot of users
with profile corruption caused by sharing profiles between Netscape and Mozilla.
That could lead to user frustration.
Comment 7 Conrad Carlen (not reading bugmail) 2002-06-06 07:16:32 PDT
More closely related is bug 107694. See
http://bugzilla.mozilla.org/show_bug.cgi?id=107694#c6.

  What I was talking about when I made that comment was to fix bugs such as this
which cause the problem of using the same profile (non-concurrently) between
mozilla and NS. Then, we wouldn't *have* to have separate profiles between
products as bug 107694 calls for.

  Now, I think that it would be nice to *be able to* have separate profile dirs
for the sake of distributors. For that, see bug 58327. 
Comment 8 Ed Hume 2002-12-28 08:27:31 PST
The problem with running the same profile alternately in NS and Moz is that some
themes work only for some Moz versions and not in NS7. If Moz is set for such a
theme, display problems ensue.

Work-arounds:

1. Two Profiles, each named clearly enough to indicated which profile is used
with which browser.

2. Shortcuts that aim the browser at a particular profile, as "C:\Program
Files\mozilla.org\Mozilla\mozilla.exe" "-p" "MozProfileName" (a Windows XP example)

Obviously these are kludges.

A potential fix: since NS isn't moving, move Moz, from the "Mozilla" application
directory to a "Mozilla.org" or "Moz" directory.
Comment 9 kguru 2003-01-25 21:10:40 PST
Mozilla should prompt a user to create a seperate Mozilla profile if the
existing profile was made by Netscape.  Conversely, Netscape should prompt a
user to create a seperate Netscape profile if the existing profile was made by
Mozilla.  When I accidently share the Netscape profile with Mozilla it usually
becomes corrupt because features implemented in Mozilla are not yet in Netscape.
 Also the bookmarks erroneously double import and become disorganized.
Comment 10 Ben Bucksch (:BenB) 2003-02-11 20:35:14 PST
I totally agree with comment 3. The software by default does the wrong thing,
without a warning, so you cannot blame the user, the software is broken.

There is a bug about Netscape using a different directory.
Comment 11 Samir Gehani 2003-04-29 17:00:16 PDT
adt: nsbeta1-
Comment 12 Asa Dotzler [:asa] 2003-12-12 12:20:06 PST
->prefs backend.
Comment 13 Aaron Leventhal 2005-02-18 20:57:40 PST
What's a Netscape? :)

Ancient history, right?
Comment 14 Matt Seitz 2005-02-20 22:15:30 PST
Netscape is not ancient history to me.  I just installed Netscape 7.2 on a
system last week.  Netscape 8 Beta is about to be released
(http://browser.netscape.com/nsb/).  

It's annoying to have to switch profiles when running Netscape and Mozilla on
the same machine.  Please reopen this bug.
Comment 15 Matt Seitz 2006-03-26 16:10:46 PST
I withdraw my request to reopen this bug.  Netscape seems to no longer be using the Mozilla profile code. 

Note You need to log in before you can comment on or make changes to this bug.