If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Android] Permaorange in test_execute_script.py TestExecuteContent.test_return_value_on_alert when Gecko 55 merges to beta on 2017-06-12

RESOLVED FIXED in Firefox 55

Status

Testing
Marionette
RESOLVED FIXED
3 months ago
3 months ago

People

(Reporter: RyanVM, Assigned: RyanVM)

Tracking

unspecified
mozilla56
Unspecified
Android
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox53 unaffected, firefox54 unaffected, firefox55+ fixed, firefox56 fixed)

Details

(Assignee)

Description

3 months ago
[Tracking Requested - why for this release]: Permaorange

Tier 2, so not blocking the merge, but a permafail nonetheless.

https://treeherder.mozilla.org/logviewer.html#?job_id=106008959&repo=try

Updated

3 months ago
Flags: needinfo?(hskupin)
Hard to say without proper logs but I would assume this is due to bug 1341466.

Geoff, what do you think?
Flags: needinfo?(hskupin) → needinfo?(gbrown)

Comment 2

3 months ago
I do not think this is really bug 1341466. The emulator is generally reliable > 95% of the time, so it seems unlikely that sudden emulator failure is causing a permaorange for this job. Also, I see socket timeouts in the log, rather than adb timeouts.

On the other hand, of course there is a similar issue, in that the job is running > 3600 seconds because it doesn't give up and keeps encountering long-running failures. Since the job times out after 3600 seconds, there are fewer diagnostics available. :(

It would be nice to see a logcat for this -- it might tell us what is happening on the device.
Flags: needinfo?(gbrown)
Ok, so I had another look at this and you are right, Geoff! The problematic test in question here is `test_return_value_on_alert`. And it has been added recently by Andreas on bug 1370850.

In general we do not have any modal/tabmodal dialog test running for Fennec. But the patch added a test for tab modal dialogs which also gets run in Fennec. So this should not have been done. Whereby I still wonder why we do not have a permanent failure on Android for Nightly!

Andreas, can you please disable the test? Thanks.
Blocks: 1370850
Flags: needinfo?(ato)
Summary: Permaorange in test_execute_script.py on Android debug when Gecko 55 merges to beta on 2017-06-12 → [Android] Permaorange in test_execute_script.py TestExecuteContent.test_return_value_on_alert when Gecko 55 merges to beta on 2017-06-12
(Assignee)

Comment 4

3 months ago
Per IRC
Assignee: nobody → ryanvm
Flags: needinfo?(ato)

Comment 5

3 months ago
Pushed by ryanvm@gmail.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/def7c269d7af
Skip test_execute_script.py TestExecuteContent.test_return_value_on_alert on Android. r=ato
(Assignee)

Comment 6

3 months ago
bugherderuplift
https://hg.mozilla.org/releases/mozilla-beta/rev/7ffb29adc25b
status-firefox55: affected → fixed

Comment 7

3 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/def7c269d7af
Status: NEW → RESOLVED
Last Resolved: 3 months ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Duplicate of this bug: 1371905
tracking-firefox55: ? → +
You need to log in before you can comment on or make changes to this bug.