Closed Bug 1372583 Opened 5 years ago Closed 5 years ago

Hide about:preferences#containers panel in search result

Categories

(Firefox :: Preferences, defect, P1)

56 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 56
Tracking Status
firefox54 --- unaffected
firefox55 --- wontfix
firefox56 --- verified

People

(Reporter: hani.yacoub, Assigned: rickychien)

References

(Blocks 1 open bug)

Details

(Whiteboard: [photon-preference])

Attachments

(3 files)

Attached video Recording #11.mp4
[Affected versions]:
Nightly 56.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Launch Firefox, go to about:config and search for "browser.preferences.search" and set it value to true.
2. Go to "about:preferences".
3. Search "Banking" on search input field or "Add new container".
4. Search for "Remove".

[Expected result]:
All the elements from "about:preferences#containers" are displayed when searching for a key word with out displayed "Container Tabs" section.

[Actual result]:
- Both "Settings..." button and Banking in "about:preferences#containers" are Highlighted.
- Remove button is not highlighted.
Blocks: 1357285
Whiteboard: [photon-preference]
Whiteboard: [photon-preference] → [photon-preference][triage]
Target Milestone: --- → Firefox 56
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Has STR: --- → yes
Flags: qe-verify+
Priority: -- → P1
QA Contact: hani.yacoub
Summary: Both "Settings..." button and the key word searched in "about:preferences#containers" are highlighted → Hide about:preferences#containers panel in search result
Whiteboard: [photon-preference][triage] → [photon-preference]
Per discussion with UX designer, we're going to hide container panel from search result but only display the tooltip on top of the "Settings..." button instead. (Please see expected result as attached screenshot)

In other words, text content inside container panel won't be highlighted anymore since clicking container's "Settings..." button will leave the search result and no highlight is necessary.
Added data-hidden-from-search="true" in container panel for hiding itself from search result but introduced a new data-subpanel="true" attribute for being able to display container panel on preferences panel.
Comment on attachment 8877858 [details]
Bug 1372583 - Hide about:preferences#containers panel in search result

https://reviewboard.mozilla.org/r/149284/#review155376

::: browser/components/preferences/in-content-new/containers.xul:32
(Diff revision 2)
>        data-category="paneContainers">
>    <label class="header-name" flex="1">&paneContainers.title;</label>
>  </hbox>
>  
>  <!-- Containers -->
> -<groupbox id="browserContainersGroup" data-category="paneContainers" hidden="true">
> +<groupbox id="browserContainersGroup" data-category="paneContainers" hidden="true"

I just noticed that this has the same ID as the checkbox groupbox. Please change this ID to "browserContainersGroupPane" and make sure that changing the name doesn't break any JS.
Attachment #8877858 - Flags: review?(jaws) → review+
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/7730adc9cfea
Hide about:preferences#containers panel in search result r=jaws
https://hg.mozilla.org/mozilla-central/rev/7730adc9cfea
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Build ID: 20170620030208
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Verified as fixed on Firefox Nightly 56.0a1 on Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.