Remove or update customization mode infopanel

VERIFIED FIXED in Firefox 56

Status

()

enhancement
P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: Dolske, Assigned: Gijs)

Tracking

(Blocks 2 bugs)

Trunk
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 verified)

Details

(Whiteboard: [photon-structure])

Attachments

(3 attachments)

Posted image Screen Shot
The first time customization mode is opened, we show a little infopanel that explains what can be done.

Assuming we want to keep this, the illustration should be updated since it shows the pre-Photon hamburger menu (icons in a grid) and other browser UI.

Might also want to tweak the copy, I'm not sure why it says "any of the above". 

Also it links to https://support.mozilla.org/en-US/kb/customize-firefox-controls-buttons-and-toolbars?as=u&utm_source=inproduct, which should be updated too.
The super-safe / low effort option for photon if we can't get to this would be to perma-pref this off, as there's a pref we check before showing it (which we use to avoid showing it more than once, but can obviously leverage to just never show this).

I'd be in favour of just removing it - I think we will have an onboarding tour that helps with the important bits, not convinced that a one-time help panel here will be that useful.
Whiteboard: [photon-structure][triage]
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [photon-structure][triage] → [photon-structure]
Assignee: nobody → gijskruitbosch+bugs
Status: NEW → ASSIGNED
Iteration: --- → 56.2 - Jul 10
Priority: P2 → P1
Duplicate of this bug: 1373703
Flags: qe-verify? → qe-verify+
QA Contact: gwimberly
Comment on attachment 8881786 [details]
Bug 1373016 - switch from a tip panel to a permanent message for empty overflow panels in customize mode for photon,

https://reviewboard.mozilla.org/r/152854/#review158062

::: browser/themes/shared/customizableui/customizeMode.inc.css:581
(Diff revision 1)
> +#customization-panelHolder > #widget-overflow-fixed-list:not(:empty) {
> +  padding-bottom: 50px; /* Make sure there's always space to drop stuff. */
> +}
> +
> +#customization-panelHolder > #widget-overflow-fixed-list:empty {
> +  background: url("chrome://browser/skin/customizableui/empty-overflow-panel.png") center top 10px/218px 134px no-repeat;

Please use the long-hand version of these properties.

What does the 218px number come from?
Attachment #8881786 - Flags: review?(jaws) → review+
(In reply to Jared Wein [:jaws] (please needinfo? me) from comment #4)
> What does the 218px number come from?

It's the size of the image - 218x134. I don't know why it's that size, hence centering it...
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/bdcdd4d23c77
switch from a tip panel to a permanent message for empty overflow panels in customize mode for photon, r=jaws
backed out for bustage like https://treeherder.mozilla.org/logviewer.html#?job_id=110681213&repo=autoland
Flags: needinfo?(gijskruitbosch+bugs)
(In reply to Carsten Book [:Tomcat] from comment #9)
> backed out for bustage like
> https://treeherder.mozilla.org/logviewer.html#?job_id=110681213&repo=autoland

I am an idiot. Forgot to 'hg add' the image files. Fixed now.
Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/5de26737d215
switch from a tip panel to a permanent message for empty overflow panels in customize mode for photon, r=jaws
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/49739b62d4dc
Backed out changeset bdcdd4d23c77 for bustage
sorry gijs, backed out for https://treeherder.mozilla.org/logviewer.html#?job_id=110688226&repo=autoland
Flags: needinfo?(gijskruitbosch+bugs)
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/d2aff6fc075d
Backed out changeset 5de26737d215 for failure like missing chrome://browser/skin/customizableui/info-icon-customizeTip@2x.png referenced from chrome://browser/skin/browser.css
Blocks: 1343824
So I missed the fact that the styling for the hidpi images wasn't ifdef'd out, because it was in osx-only and I wrote the patch on (hidpi!) windows, and my new styling was in a shared file... I ran the failing test on Windows prior to the previous landing, and it passed there. :-(

X-ref bug 1343824 which we'll end up fixing once we unship the non-MOZ_PHOTON_THEME configuration.

Anyway, ifdef'd out the OS X hidpi old-style imagery in browser.css, pulled the changes onto my mbp, re-ran the test there, passes. So, fingers crossed, let's try this a third time (as I don't see any other relevant orange on the previous push...).
Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/cbf0368eea83
switch from a tip panel to a permanent message for empty overflow panels in customize mode for photon, r=jaws
backed out for https://treeherder.mozilla.org/logviewer.html#?job_id=110718365&repo=autoland on windows
Flags: needinfo?(gijskruitbosch+bugs)
Backout by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30e0a16443c1
Backed out changeset cbf0368eea83 for unused whitelist entry: chrome://browser/skin/customizableui/customize-illustration-rtl@2x.png -
I am having such a great day. :-)

https://treeherder.mozilla.org/#/jobs?repo=try&revision=cd84731804b7

looks green (apart from OS X, which is lagging behind, but was green on https://treeherder.mozilla.org/#/jobs?repo=autoland&revision=cbf0368eea83774a4ecf41b798f1c6b442b72568 , so let's try again...
Flags: needinfo?(gijskruitbosch+bugs)
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/9f0b68036edb
switch from a tip panel to a permanent message for empty overflow panels in customize mode for photon, r=jaws
https://hg.mozilla.org/mozilla-central/rev/9f0b68036edb
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Verified on Windows and Ubuntu, but I'm still seeing this on the Mac build as of 7/5's nightly. Is this intended?
Flags: needinfo?(gijskruitbosch+bugs)
I noticed on Comment 21 that it was having issues, but it doesn't look like it ever went through.
Screenshot of Customize window on Mac OSX

photon.structure.enabled is set to true
Build is 20170705150303
We figured out the issue on IRC; Verified on Windows, Mac, and Linux.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
Flags: needinfo?(gijskruitbosch+bugs)
Blocks: 1387512
You need to log in before you can comment on or make changes to this bug.