If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

It's hard to figure out what the arrow panel means, in new customize mode.

RESOLVED DUPLICATE of bug 1373016

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 1373016
4 months ago
4 months ago

People

(Reporter: arai, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 months ago
Steps to reproduce:
  1. open Nightly 56.0a1 (2017-06-16) (64-bit) on macOS
  2. click hamburger button
  3. click "Customize..." menu item

Actual result:
  the right side of the window shows some arrow panel, that looks like previous hamburger menu, but it's empty, and apparently it's not the hamburger menu.

Expected result:
  it become clearer what it is.

the issue is that:
  1. it doesn't explain what it is
  2. the arrow panel's arrow is off from the ">>" button and doesn't point the button
  3. it's not clear why it's empty
  4. when I drag and drop item to ">>" button, it opens extra arrow panel (maybe better filing another bug for it tho...)
(In reply to Tooru Fujisawa [:arai] from comment #0)
> the issue is that:
>   1. it doesn't explain what it is

bug 1373016

>   2. the arrow panel's arrow is off from the ">>" button and doesn't point
> the button

bug 1354123 / bug 1354145 will fix this.

>   3. it's not clear why it's empty

... because there's nothing in it? I don't really understand this point.

>   4. when I drag and drop item to ">>" button, it opens extra arrow panel
> (maybe better filing another bug for it tho...)

bug 1371236
No longer blocks: 1372309
Depends on: 1354145
(Reporter)

Comment 2

4 months ago
thanks.

(In reply to :Gijs from comment #1)
> >   3. it's not clear why it's empty
> 
> ... because there's nothing in it? I don't really understand this point.

I expect that area to show items in the menu that "Customize..." menu item was in, just like before.
so, maybe it's the same as 1, and bug 1373016.
(In reply to Tooru Fujisawa [:arai] from comment #2)
> thanks.
> 
> (In reply to :Gijs from comment #1)
> > >   3. it's not clear why it's empty
> > 
> > ... because there's nothing in it? I don't really understand this point.
> 
> I expect that area to show items in the menu that "Customize..." menu item
> was in, just like before.
> so, maybe it's the same as 1, and bug 1373016.

It's the overflow panel, not the hamburger panel, so it has no items by default. The hamburger panel can no longer be customized. See https://dolske.wordpress.com/2017/06/15/photon-engineering-newsletter-6/ .
(Reporter)

Comment 4

4 months ago
(In reply to :Gijs from comment #3)
> The hamburger panel can no longer be customized.

is there any reason?
bug 1354145 already helps a bit here because the arrow will point to the right place, but the proper fix is bug 1373016, so duping there.
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1373016
No longer depends on: 1354145
You need to log in before you can comment on or make changes to this bug.