SeaMonkey is incorrectly enclosed in quotation marks in Set Default Programs dialog

RESOLVED FIXED in seamonkey2.55

Status

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: frg, Assigned: frg)

Tracking

Trunk
seamonkey2.55
All
Windows

SeaMonkey Tracking Flags

(seamonkey2.48 wontfix, seamonkey2.49esr fixed, seamonkey2.50 wontfix, seamonkey2.51 wontfix, seamonkey2.52 wontfix, seamonkey2.53 fixed, seamonkey2.54 fixed, seamonkey2.55 fixed)

Details

Attachments

(2 attachments, 2 obsolete attachments)

Tile says it all.

SeaMonkey (Mail) and SeaMonkey (News) are not affected.
Posted image Capture.PNG
picture showing the problem.
Posted patch 1373374-quotationmarks.patch (obsolete) — Splinter Review
SeaMonkey currently is the only product defining them in moz.build so align the installers with TB and IB.
Attachment #8878185 - Flags: review?(rsx11m.pub)
REPRODUCIBLE with Installation of unofficial (by FRG) DE SeaMonkey 2.49.1  (NT 6.1; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0 Build 20170511042150  (Default Classic Theme) on German WIN7 64bit, I see those single quotation marks around SeaMonkey. But I can't tell which installation caused this mistake.
> But I can't tell which installation caused this mistake.

Must have been so for ages in moz.build. See "'%s'" in 

> DEFINES['MOZ_APP_DISPLAYNAME'] = "'%s'" % CONFIG['MOZ_APP_DISPLAYNAME']
Attachment #8878185 - Flags: review?(rsx11m.pub) → review?(iann_bugzilla)
Comment on attachment 8878185 [details] [diff] [review]
1373374-quotationmarks.patch

The correct thing to do would be to port Bug 1225918 - avoid quoting MOZ_APP_DISPLAYNAME when used as a DEFINE
Attachment #8878185 - Flags: review?(iann_bugzilla) → review-
Made the patch simpler :)
Attachment #8878185 - Attachment is obsolete: true
Comment adjusted. Tested and working.

[Approval Request Comment]
Regression caused by (bug #): --
User impact if declined: cosmetic
Testing completed (on m-c, etc.):c-b 
Risk to taking this patch (and alternatives if risky): low/no risk
String changes made by this patch: none
Attachment #8904074 - Attachment is obsolete: true
Attachment #8904143 - Flags: review?(iann_bugzilla)
Attachment #8904143 - Flags: approval-comm-release?
Attachment #8904143 - Flags: approval-comm-esr52?
Attachment #8904143 - Flags: approval-comm-beta?
Comment on attachment 8904143 [details] [diff] [review]
1373374-quotationmarks-V2.patch

r/a=me
Attachment #8904143 - Flags: review?(iann_bugzilla)
Attachment #8904143 - Flags: review+
Attachment #8904143 - Flags: approval-comm-release?
Attachment #8904143 - Flags: approval-comm-release+
Attachment #8904143 - Flags: approval-comm-esr52?
Attachment #8904143 - Flags: approval-comm-esr52+
Attachment #8904143 - Flags: approval-comm-beta?
Attachment #8904143 - Flags: approval-comm-beta+
Pushed by frgrahl@gmx.net:
https://hg.mozilla.org/comm-central/rev/4415a4c2c949
Remove single quotation marks around MOZ_APP_DISPLAYNAME in SeaMonkey installer. r=IanN
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.