Closed Bug 1225918 Opened 4 years ago Closed 4 years ago

Firefox installer is referring to Firefox as 'Firefox' (extra quotes)

Categories

(Firefox :: Installer, defect)

43 Branch
x86_64
Windows
defect
Not set

Tracking

()

VERIFIED FIXED
Firefox 45
Tracking Status
firefox42 - wontfix
firefox43 - fixed
firefox44 - fixed
firefox45 - verified

People

(Reporter: gcp, Assigned: froydnj)

References

Details

Attachments

(2 files)

It looks like some extra quotation marks slipped into the installer scripts. Every screen in the (stub) installer is referring to the product as 'Firefox' instead of just Firefox. It looks pretty awkward and strange.
Reportedly this also affects the program name when shown in the Windows Default Programs dialog, which means it's surely a bug.
https://hg.mozilla.org/mozilla-central/rev/bdfaafcf994b

+DEFINES['MOZ_APP_DISPLAYNAME'] = "'%s'" % CONFIG['MOZ_APP_DISPLAYNAME']

Doesn't this add extra quotes?
Flags: needinfo?(nfroyd)
Blocks: 1185637
Moving DEFINES from Makefile.in to moz.build in
browser/installer/windows/ kept the single quotes for
MOZ_APP_DISPLAYNAME.  Unfortunately, the patch author missed that those
quotes were there for the shell's benefit, not as a part of the defined
value.  These extraneous quotes look rather unbecoming in the installer.

Since mozbuild adds the appropriate quoting to a defined value, we can
simply forego the quoting in the moz.build file.

I haven't tested this on a Windows machine yet (I'm not even certain I can
build and run the installer!), but the reasoning makes some sense...
Attachment #8689144 - Flags: review?(mshal)
[Tracking Requested - why for this release]: Cosmetic problems in the installer due to bug 1185637.
Flags: needinfo?(nfroyd)
I have experienced this in every Firefox version at least for 3-4 weeks, but I thought it should be like this.
Attachment #8689144 - Flags: review?(mshal) → review+
https://hg.mozilla.org/mozilla-central/rev/e665231d446b
Status: NEW → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 45
Tracked for 44.
Nathan, should we consider uplifting this fix to Aurora44?
Flags: needinfo?(nfroyd)
(In reply to Ritu Kothari (:ritu) from comment #9)
> Nathan, should we consider uplifting this fix to Aurora44?

We should fix this in 44 and 43, if we can; 42 already went out the door with this. :(  Will write uplift request shortly.
Flags: needinfo?(nfroyd)
Comment on attachment 8689144 [details] [diff] [review]
avoid quoting MOZ_APP_DISPLAYNAME when used as a DEFINE

Approval Request Comment
[Feature/regressing bug #]: Bug 1185637
[User impact if declined]: Unusual quoting in the installer; not significant user impact, but definitely a fit-and-finish sort of bug.
[Describe test coverage new/current, TreeHerder]: Not really applicable here.
[Risks and why]: Low low risk.
[String/UUID change made/needed]: None, this just touches internal build files.
Attachment #8689144 - Flags: approval-mozilla-beta?
Attachment #8689144 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1220930
Assignee: nobody → nfroyd
Comment on attachment 8689144 [details] [diff] [review]
avoid quoting MOZ_APP_DISPLAYNAME when used as a DEFINE

Trivial fix for a recent regression, OK to uplift to aurora and beta.
Attachment #8689144 - Flags: approval-mozilla-beta?
Attachment #8689144 - Flags: approval-mozilla-beta+
Attachment #8689144 - Flags: approval-mozilla-aurora?
Attachment #8689144 - Flags: approval-mozilla-aurora+
I don't think we need to track this, it's so minor, and looks fixed now.
QA Whiteboard: [good first verify]
Could not reproduce on firefox 43.0a1 or 45.0a1 build. I am using Windows 10(32 bit OS) X64 based architecture machine. Can you point me to the build to reproduce the bug before verifying?
(In reply to Chandrakant Dhutadmal from comment #18)
> Could not reproduce on firefox 43.0a1 or 45.0a1 build. I am using Windows
> 10(32 bit OS) X64 based architecture machine. Can you point me to the build
> to reproduce the bug before verifying?

Did you use the stub installer? with this build [1] you will see the extra quotes for Nightly right after the installer launches.  

[1]https://archive.mozilla.org/pub/firefox/nightly/2015/11/2015-11-18-03-02-32-mozilla-central/firefox-45.0a1.en-US.win32.installer-stub.exe
(In reply to Alexandra Lucinet, QA Mentor [:adalucinet] from comment #19)
> (In reply to Chandrakant Dhutadmal from comment #18)
> > Could not reproduce on firefox 43.0a1 or 45.0a1 build. I am using Windows
> > 10(32 bit OS) X64 based architecture machine. Can you point me to the build
> > to reproduce the bug before verifying?
> 
> Did you use the stub installer? with this build [1] you will see the extra
> quotes for Nightly right after the installer launches.  
> 
> [1]https://archive.mozilla.org/pub/firefox/nightly/2015/11/2015-11-18-03-02-
> 32-mozilla-central/firefox-45.0a1.en-US.win32.installer-stub.exe

I could find out the issue in 45.0a1. Was confused with the title in the installer Window. It reads 'Nightly' setup. The title mentioned in this bug is 'Firefox' instead. I am attaching the screenshot which I captured (ExtraQuotesIssue-45.0a1Build.png). I hope this is the issue which the reporter of the bug is talking about.
(In reply to Chandrakant Dhutadmal from comment #20)
> I could find out the issue in 45.0a1. Was confused with the title in the
> installer Window. It reads 'Nightly' setup. The title mentioned in this bug
> is 'Firefox' instead. I am attaching the screenshot which I captured
> (ExtraQuotesIssue-45.0a1Build.png). I hope this is the issue which the
> reporter of the bug is talking about.

Yes, that's the case here; along with the one from the option to set the browser as default - https://goo.gl/OXmCiQ - which you don't see because you're using Windows 10 and it was intentionally removed on Windows 8+ (bug 1237592 comment 1). 
What's left for you to do here is to confirm the fix with latest builds.
Thanks for your contribution! :)
This is verified resolved in Firefox 45.0b3 installer (.exe file). Since I do not have permissions to change the staus of the bug, I am commenting here. [testday-20160205]
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.