GrayText should have ThreeDHighlight offset in Windows

RESOLVED DUPLICATE of bug 69710

Status

()

Core
XUL
RESOLVED DUPLICATE of bug 69710
16 years ago
10 years ago

People

(Reporter: Bamm Gabriana, Assigned: jag (Peter Annema))

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
The style "color: GrayText;" used to specify disabled text in user
interfaces should have a white dropshadow in Windows platforms.

This is to be consistent with the look of native Win32 apps in which
all disabled text in UI have white dropshadows.
(Reporter)

Comment 1

16 years ago
Created attachment 79121 [details]
Example of disabled text in Netscape 4.

Here is how disabled text looks in native Win32 apps. This screenshot
is taken from Netscape Communicator 4.79 under Windows 98SE.
(Reporter)

Comment 2

16 years ago
Created attachment 79122 [details]
Example of disabled text in Mozilla 2002041203.

This is how it looks in Mozilla. The plain gray letters is inconsistent
with the way this is displayed in other Win32 applications.
This is not a bug with GrayText. In CSS GrayText cannot also include a drop
shadow (and it definitely has nothing to do with the DOM). Sending to XPToolkit.
Assignee: jst → jaggernaut
Component: DOM Style → XP Toolkit/Widgets
QA Contact: ian → jrgm
Summary: GrayText should have white dropshadow in Windows → Disabled text should have white dropshadow in Windows
Whiteboard: DUPEME

Comment 4

16 years ago
Very similar to bug 69710.
(Reporter)

Comment 5

16 years ago
I disagree with comment #3. The CSS specification for GrayText is a system color
representing disabled text. Therefore it must be rendered the way the platform
renders disabled text. In Windows, this means a ThreeDShadow and a
ThreeDHighlight, with the latter offset 1 pixel to the right and bottom.
(Reporter)

Updated

16 years ago
Summary: Disabled text should have white dropshadow in Windows → GrayText should have white dropshadow in Windows
(Reporter)

Updated

16 years ago
Summary: GrayText should have white dropshadow in Windows → GrayText should have ThreeDHighlight offset in Windows

Comment 6

16 years ago
If this turns out not to be a dup then it depends on bug 10713.
(Reporter)

Updated

16 years ago
Status: UNCONFIRMED → NEW
Depends on: 10713
Ever confirmed: true
Whiteboard: DUPEME

Comment 7

10 years ago
(In reply to comment #5)
> The CSS specification for GrayText is a system
> color
> representing disabled text. Therefore it must be rendered the way the platform
> renders disabled text. In Windows, this means a ThreeDShadow and a
> ThreeDHighlight, with the latter offset 1 pixel to the right and bottom.

No, this is technically wrong. A CSS color is only a color, not a decoration.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
No longer depends on: 10713
Resolution: --- → DUPLICATE
Duplicate of bug: 69710
You need to log in before you can comment on or make changes to this bug.