Stop using the :not(:target) selector in the video element's SVG icons

RESOLVED FIXED in Firefox 56

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: jwatt, Assigned: jwatt)

Tracking

(Blocks 1 bug, {perf})

unspecified
Firefox 56
Points:
---

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(4 attachments)

Comment hidden (empty)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 7

2 years ago
mozreview-review
Comment on attachment 8878938 [details]
Bug 1374106, part 1 - Remove duplication in the styling of the video elemnent's play/pause button.

https://reviewboard.mozilla.org/r/150182/#review155788
Attachment #8878938 - Flags: review?(dao+bmo) → review+

Comment 8

2 years ago
mozreview-review
Comment on attachment 8878939 [details]
Bug 1374106, part 2 - Split up the video control mute/unmute/no-audio icon and convert it to use SVG context paint.

https://reviewboard.mozilla.org/r/150184/#review155794

::: toolkit/themes/shared/media/videocontrols.css:166
(Diff revision 2)
>  }
>  
>  .fullscreenButton {
> -  background-image: url(chrome://global/skin/media/fullscreenButton.svg#fullscreen);
> +  background-image: url(chrome://global/skin/media/fullscreenEnterButton.svg);
> +  -moz-context-properties: fill;
> +  fill: white;

please add a new rule for .closedCaptionButton and .fullscreenButton setting both -moz-context-properties and fill

::: toolkit/themes/shared/media/videocontrols.css:169
(Diff revision 2)
> -  background-image: url(chrome://global/skin/media/fullscreenButton.svg#fullscreen);
> +  background-image: url(chrome://global/skin/media/fullscreenEnterButton.svg);
> +  -moz-context-properties: fill;
> +  fill: white;
>  }
>  .fullscreenButton:hover {
> -  background-image: url(chrome://global/skin/media/fullscreenButton.svg#fullscreen-hover);
> +  fill: #48a0f7;

please merge this with the .closedCaptionButton:hover rule

::: toolkit/themes/shared/media/videocontrols.css:172
(Diff revision 2)
>  }
>  .fullscreenButton:hover {
> -  background-image: url(chrome://global/skin/media/fullscreenButton.svg#fullscreen-hover);
> +  fill: #48a0f7;
>  }
>  .fullscreenButton:hover:active {
> -  background-image: url(chrome://global/skin/media/fullscreenButton.svg#fullscreen-active);
> +  fill: #2d89e6;

please merge this with the .closedCaptionButton:hover:active rule
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)
Comment hidden (mozreview-request)

Comment 13

2 years ago
mozreview-review
Comment on attachment 8878939 [details]
Bug 1374106, part 2 - Split up the video control mute/unmute/no-audio icon and convert it to use SVG context paint.

https://reviewboard.mozilla.org/r/150184/#review156108
Attachment #8878939 - Flags: review?(dao+bmo) → review+

Comment 14

2 years ago
mozreview-review
Comment on attachment 8878940 [details]
Bug 1374106, part 3 - Split up the video control closed captions on/off icon and convert it to use SVG context paint.

https://reviewboard.mozilla.org/r/150186/#review156110
Attachment #8878940 - Flags: review?(dao+bmo) → review+

Comment 15

2 years ago
mozreview-review
Comment on attachment 8879684 [details]
Bug 1374106, part 4 - Split up the video control enter/exit fullscreen icon and convert it to use SVG context paint.

https://reviewboard.mozilla.org/r/151024/#review156112

::: toolkit/themes/shared/media/videocontrols.css:110
(Diff revision 1)
>  }
>  
>  .playButton:hover:active,
>  .muteButton:hover:active,
> -.closedCaptionButton:hover:active {
> +.closedCaptionButton:hover:active,
> +.fullscreenButton:hover:active{

nit: space before {
Attachment #8879684 - Flags: review?(dao+bmo) → review+

Comment 16

2 years ago
Pushed by jwatt@jwatt.org:
https://hg.mozilla.org/integration/mozilla-inbound/rev/0d9b6c6b5a1f
part 1 - Remove duplication in the styling of the video elemnent's play/pause button. r=dao
https://hg.mozilla.org/integration/mozilla-inbound/rev/6e1bc3cb371b
part 2 - Split up the video control mute/unmute/no-audio icon and convert it to use SVG context paint. r=dao
https://hg.mozilla.org/integration/mozilla-inbound/rev/0848cd235cd7
part 3 - Split up the video control closed captions on/off icon and convert it to use SVG context paint. r=dao
https://hg.mozilla.org/integration/mozilla-inbound/rev/c132f4ee269d
part 4 - Split up the video control enter/exit fullscreen icon and convert it to use SVG context paint. r=dao

Updated

2 years ago
Duplicate of this bug: 1367957
You need to log in before you can comment on or make changes to this bug.