videos are not scaled properly, have green borders

RESOLVED DUPLICATE of bug 1352016

Status

()

RESOLVED DUPLICATE of bug 1352016
a year ago
a year ago

People

(Reporter: torvin, Unassigned)

Tracking

55 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8878993 [details]
screenshot

User Agent: Mozilla/5.0 (Windows NT 6.2; Win64; x64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170615070049

Steps to reproduce:

Open any video. E.g. this one from 9gag:

http://img-9gag-ftw.9cache.com/photo/avG77pZ_460sv.mp4


Actual results:

The video doesn't occupy the whole videobox. You can see the green background in the unoccupied areas (see screenshot attached). This is happening ever since I upgraded to FF55


Expected results:

The video should be displayed properly
(Reporter)

Comment 1

a year ago
I tested this on a clean new profile and it is still reproducible. However, if I restart FF in the safe mode, the problem goes away.
Component: Untriaged → Audio/Video: Playback
Product: Firefox → Core
Torvin, can you try to find a regression range for this? You can use mozregression to help you with that. http://mozilla.github.io/mozregression/quickstart.html
Flags: needinfo?(torvin)
(Reporter)

Comment 3

a year ago
I've done it. What should I post? Would that be enough?

app_name: firefox
build_date: 2017-03-08 09:15:20.849000
build_file: C:\Users\username\.mozilla\mozregression\persist\835425e189a5--mozilla-inbound--firefox-55.0a1.en-US.win64.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/FWCLNTTKSxOUKsGM81yr4Q/runs/0/artifacts/public%2Fbuild%2Ffirefox-55.0a1.en-US.win64.zip
changeset: 835425e189a5b19703e4f2202e3d96f9629da41f
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=4e90c48f26179dc59150ae002a46666014fd3cbc&tochange=835425e189a5b19703e4f2202e3d96f9629da41f
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: FWCLNTTKSxOUKsGM81yr4Q
Flags: needinfo?(torvin)
(Reporter)

Comment 4

a year ago
Also a few last lines from the log just in case:

2017-06-20T12:15:49: INFO : Narrowed inbound regression window from [0ab16c81, 0d4603eb] (3 revisions) to [9a09749b, 0d4603eb] (2 revisions) (~1 steps left)
2017-06-20T12:15:49: DEBUG : Starting merge handling...
2017-06-20T12:15:49: DEBUG : Using url: https://hg.mozilla.org/integration/mozilla-inbound/json-pushes?changeset=0d4603ebe97ee5e364be000ebfa5e5121be17e11&full=1
2017-06-20T12:15:50: DEBUG : Found commit message:
Bug 1340398 - Part 3: Use NV12 format by default. r=mattwoodrow

MozReview-Commit-ID: DcP40U81FBQ

2017-06-20T12:15:50: INFO : The bisection is done.
2017-06-20T12:15:50: INFO : Stopped
(Reporter)

Comment 5

a year ago
Please ignore Comment 3. this is the last version tested:

app_name: firefox
build_date: 2017-03-08 08:26:38.716000
build_file: C:\Users\username\.mozilla\mozregression\persist\9a09749bb230--mozilla-inbound--firefox-55.0a1.en-US.win64.zip
build_type: inbound
build_url: https://queue.taskcluster.net/v1/task/aIkHtn1NQhOHTenQzvJplQ/runs/0/artifacts/public%2Fbuild%2Ffirefox-55.0a1.en-US.win64.zip
changeset: 9a09749bb23088cd008d05194c5abe8c4f1fb838
pushlog_url: https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=9a09749bb23088cd008d05194c5abe8c4f1fb838&tochange=0d4603ebe97ee5e364be000ebfa5e5121be17e11
repo_name: mozilla-inbound
repo_url: https://hg.mozilla.org/integration/mozilla-inbound
task_id: aIkHtn1NQhOHTenQzvJplQ
See Also: → bug 1352016
(Reporter)

Comment 6

a year ago
Here's my Graphics section from about:support

Features
Compositing	Direct3D 11
Asynchronous Pan/Zoom	none
WebGL 1 Driver WSI Info	EGL_VENDOR: Google Inc. (adapter LUID: 0000000000008a36)
EGL_VERSION: 1.4 (ANGLE 2.1.0.dec065540d5f)
EGL_EXTENSIONS: EGL_EXT_create_context_robustness EGL_ANGLE_d3d_share_handle_client_buffer EGL_ANGLE_d3d_texture_client_buffer EGL_ANGLE_surface_d3d_texture_2d_share_handle EGL_ANGLE_query_surface_pointer EGL_ANGLE_window_fixed_size EGL_ANGLE_keyed_mutex EGL_ANGLE_surface_orientation EGL_ANGLE_direct_composition EGL_NV_post_sub_buffer EGL_KHR_create_context EGL_EXT_device_query EGL_KHR_image EGL_KHR_image_base EGL_KHR_gl_texture_2D_image EGL_KHR_gl_texture_cubemap_image EGL_KHR_gl_renderbuffer_image EGL_KHR_get_all_proc_addresses EGL_KHR_stream EGL_KHR_stream_consumer_gltexture EGL_NV_stream_consumer_gltexture_yuv EGL_ANGLE_flexible_surface_compatibility EGL_ANGLE_stream_producer_d3d_texture_nv12 EGL_ANGLE_create_context_webgl_compatibility EGL_CHROMIUM_create_context_bind_generates_resource 
EGL_EXTENSIONS(nullptr): EGL_EXT_client_extensions EGL_EXT_platform_base EGL_EXT_platform_device EGL_ANGLE_platform_angle EGL_ANGLE_platform_angle_d3d EGL_ANGLE_device_creation EGL_ANGLE_device_creation_d3d11 EGL_ANGLE_experimental_present_path EGL_KHR_client_get_all_proc_addresses 
WebGL 1 Driver Renderer	Google Inc. -- ANGLE (NVIDIA GeForce 9600 GT Direct3D11 vs_4_0 ps_4_0)
WebGL 1 Driver Version	OpenGL ES 2.0 (ANGLE 2.1.0.dec065540d5f)
WebGL 1 Driver Extensions	GL_ANGLE_depth_texture GL_ANGLE_framebuffer_blit GL_ANGLE_framebuffer_multisample GL_ANGLE_instanced_arrays GL_ANGLE_lossy_etc_decode GL_ANGLE_pack_reverse_row_order GL_ANGLE_request_extension GL_ANGLE_robust_client_memory GL_ANGLE_texture_compression_dxt3 GL_ANGLE_texture_compression_dxt5 GL_ANGLE_texture_usage GL_ANGLE_translated_shader_source GL_CHROMIUM_bind_generates_resource GL_CHROMIUM_bind_uniform_location GL_CHROMIUM_copy_compressed_texture GL_CHROMIUM_copy_texture GL_CHROMIUM_sync_query GL_EXT_blend_minmax GL_EXT_color_buffer_half_float GL_EXT_debug_marker GL_EXT_discard_framebuffer GL_EXT_disjoint_timer_query GL_EXT_draw_buffers GL_EXT_frag_depth GL_EXT_map_buffer_range GL_EXT_occlusion_query_boolean GL_EXT_read_format_bgra GL_EXT_robustness GL_EXT_sRGB GL_EXT_shader_texture_lod GL_EXT_texture_compression_dxt1 GL_EXT_texture_filter_anisotropic GL_EXT_texture_format_BGRA8888 GL_EXT_texture_rg GL_EXT_texture_storage GL_EXT_unpack_subimage GL_KHR_debug GL_NV_EGL_stream_consumer_external GL_NV_fence GL_NV_pack_subimage GL_NV_pixel_buffer_object GL_OES_EGL_image GL_OES_EGL_image_external GL_OES_compressed_ETC1_RGB8_texture GL_OES_depth32 GL_OES_element_index_uint GL_OES_get_program_binary GL_OES_mapbuffer GL_OES_packed_depth_stencil GL_OES_rgb8_rgba8 GL_OES_standard_derivatives GL_OES_texture_float GL_OES_texture_float_linear GL_OES_texture_half_float GL_OES_texture_half_float_linear GL_OES_texture_npot GL_OES_vertex_array_object 
WebGL 1 Extensions	ANGLE_instanced_arrays EXT_blend_minmax EXT_color_buffer_half_float EXT_frag_depth EXT_shader_texture_lod EXT_texture_filter_anisotropic EXT_disjoint_timer_query MOZ_debug OES_element_index_uint OES_standard_derivatives OES_texture_float OES_texture_float_linear OES_texture_half_float OES_texture_half_float_linear OES_vertex_array_object WEBGL_color_buffer_float WEBGL_compressed_texture_s3tc WEBGL_debug_renderer_info WEBGL_debug_shaders WEBGL_depth_texture WEBGL_draw_buffers WEBGL_lose_context MOZ_WEBGL_lose_context MOZ_WEBGL_compressed_texture_s3tc MOZ_WEBGL_depth_texture
WebGL 2 Driver WSI Info	-
WebGL 2 Driver Renderer	WebGL creation failed: 
* Error during ANGLE OpenGL init.
* Error during ANGLE OpenGL init.
* Error during ANGLE OpenGL init.
* Error during ANGLE OpenGL init.
* Error during ANGLE OpenGL init.
* Exhausted GL driver caps.
WebGL 2 Driver Version	-
WebGL 2 Driver Extensions	-
WebGL 2 Extensions	-
Audio Backend	wasapi
Direct2D	true
DirectWrite	true (10.0.14393.1358)
GPU #1
Active	Yes
Description	NVIDIA GeForce 9600 GT
Vendor ID	0x10de
Device ID	0x0622
Driver Version	21.21.13.4201
Driver Date	11-14-2016
Drivers	nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
Subsys ID	00000000
RAM	1024
Diagnostics
AzureCanvasAccelerated	0
AzureCanvasBackend	direct2d 1.1
AzureContentBackend	direct2d 1.1
AzureFallbackCanvasBackend	skia
failures	[GFX1-]: [D2D1.1] 4CreateBitmap failure Size(460,8613) Code: 0x80070057 format 1
Decision Log
GPU_PROCESS	
unavailable by default: Multi-process mode is not enabled
WEBRENDER	
opt-in by default: WebRender is an opt-in feature
unavailable by runtime: Build doesn't include WebRender
Failure Log
(#0) Error	[D2D1.1] 4CreateBitmap failure Size(460,8613) Code: 0x80070057 format 1
(#16) Error	[D2D1.1] 4CreateBitmap failure Size(120,15564) Code: 0x80070057 format 0
(#17) Error	[D2D1.1] 4CreateBitmap failure Size(120,15564) Code: 0x80070057 format 0
(#18) Error	[D2D1.1] 4CreateBitmap failure Size(160,16160) Code: 0x80070057 format 0
(#19) Error	[D2D1.1] 4CreateBitmap failure Size(460,9350) Code: 0x80070057 format 1
(#20) Error	[D2D1.1] 4CreateBitmap failure Size(460,9350) Code: 0x80070057 format 1
(#21) Error	[D2D1.1] 4CreateBitmap failure Size(460,11485) Code: 0x80070057 format 1
(#22) Error	[D2D1.1] 4CreateBitmap failure Size(460,9964) Code: 0x80070057 format 1
(#23) Error	[D2D1.1] 4CreateBitmap failure Size(460,9817) Code: 0x80070057 format 1
(#24) Error	[D2D1.1] 4CreateBitmap failure Size(460,19424) Code: 0x80070057 format 1
(#25) Error	[D2D1.1] 4CreateBitmap failure Size(460,20856) Code: 0x80070057 format 1
(#26) Error	[D2D1.1] 4CreateBitmap failure Size(673,10806) Code: 0x80070057 format 1
(#27) Error	[D2D1.1] 4CreateBitmap failure Size(460,12395) Code: 0x80070057 format 1
(#28) Error	[D2D1.1] 4CreateBitmap failure Size(460,13947) Code: 0x80070057 format 1
(#29) Error	[D2D1.1] 4CreateBitmap failure Size(460,11964) Code: 0x80070057 format 1
(#30) Error	[D2D1.1] 4CreateBitmap failure Size(537,13967) Code: 0x80070057 format 1
(Reporter)

Comment 7

a year ago
setting media.windows-media-foundation.allow-d3d11-dxva=false also fixes it for me
Thanks! This confirms that this is a duplicate of bug 1352016.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
See Also: bug 1352016
Duplicate of bug: 1352016
You need to log in before you can comment on or make changes to this bug.