Make it possible to resize sidebar smaller and wider

UNCONFIRMED
Unassigned

Status

()

defect
UNCONFIRMED
2 years ago
2 months ago

People

(Reporter: geoffreydebelie, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox57 wontfix)

Details

User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170615030208

Steps to reproduce:

There is a lower limit and upper limit to the resizing of the WebExtensions sidebar. I don't think the defaults are good enough. If I want my sidebar 20px wide I should be able to resize it to 20px. When I want my sidebar to have a width of 600px, I should be able to resize it to that width.
Flags: needinfo?(amckay)
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Flags: needinfo?(amckay)
Resolution: --- → DUPLICATE
Duplicate of bug: 1346490
I wasn't clear enough, let me explain. This is not a duplicate of bug 1346490 (which asks for a new API).

Currently, the user can resize the sidebar between some boundaries/limits. I merely asked to be more flexible in those boundaries/limits, for example you can't resize the sidebar to be 20px wide, because the minimum is a bit higher.

TLDR: Can we change the sidebar boundaries/limits (lower and higher) for a user to resize the sidebar width? I don't think it has implications whatoever, since we already allow the sidebar to be resized.
Status: RESOLVED → UNCONFIRMED
Flags: needinfo?(amckay)
Resolution: DUPLICATE → ---
That's a question for the Firefox UI team, so moving over there.
Component: WebExtensions: Untriaged → General
Flags: needinfo?(amckay)
Product: Toolkit → Firefox
Andy, can you needinfo someone from the UI team to make some progress with this bug report?
Flags: needinfo?(amckay)
Flags: needinfo?(amckay)
Flags: needinfo?(shorlander)
This bug isn't specifically about WebExtensions, but rather any sidebar.
Summary: Make it possible to resize WebExtensions sidebar smaller and wider → Make it possible to resize sidebar smaller and wider
I don't think there is anything wrong with decreasing the minimum and increasing the maximum width of the sidebar. 

We should just need to be sure that those values don't make it possible to break the layout or to put the sidebar into an unusable state.

Constraints on the min-width:
- It should always be wide enough to see the sidebar switcher AND the close button: e.g. https://cl.ly/1u1A3I3p321c

Constraints on the max-width:
- It should never be so wide that it's hard to resize
- It should never be so wide that it's not clear where content viewport is
- I would recommend no larger than 65% of the window width
Flags: needinfo?(shorlander)
Sounds good if the sidebar switcher can hide its label dynamically.
You need to log in before you can comment on or make changes to this bug.