Closed Bug 1374431 Opened 3 years ago Closed 3 years ago

[Photon] In customize mode, target for overflow panel is not clear

Categories

(Firefox :: Toolbars and Customization, defect, P2)

defect

Tracking

()

RESOLVED DUPLICATE of bug 1354145

People

(Reporter: hwine, Unassigned)

Details

I spent several days thinking the feature was broken because I was dropping the icons over the "field" rather than into the "bubble".

For me, the "field" was the logical equivalent of the "drop target" from pre-photon. I _assumed_ the bubble was for some other (not yet finished) usage.

From discussion in #nightly, others were also running into the same issue.

Things that would have improved my experience of transitioning from the old model include:
 - getting a message if I drop in invalid place
 - extending the bubble to fill the entire field
 - setting the "gravity" such that a drop in the field puts icon into bubble, instead of back on the pallet. (A faint trail so I could see where the icon went would be awesome.)

Now that I understand how to use it, I really like the new setup!
Whiteboard: [photon-structure]
Whiteboard: [photon-structure] → [photon-structure][triage]
Blocks: 1352693
No longer blocks: photon-structure
I suspect bug 1354145 will fix this - it removes the separate "field" area, making the "more tools" section contiguous with any 'spare' area underneath the 'bubble'. We will probably also make the panel line up more obviously with the dropmarker and style it more like a panel. See mocks at https://mozilla.invisionapp.com/share/BXBFSCU6P#/screens/229252091_Customization .
Depends on: 1354145
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [photon-structure][triage] → [photon-structure]
(In reply to :Gijs from comment #1)
> I suspect bug 1354145 will fix this ... See mocks at
> https://mozilla.invisionapp.com/share/BXBFSCU6P#/screens/229252091_Customization

+1 - that layout would have addressed all my confusion. Nice \o/

P.S. where can I get the Piranha extension you show there?
(In reply to Hal Wine [:hwine] (use NI) from comment #2)
> (In reply to :Gijs from comment #1)
> > I suspect bug 1354145 will fix this ... See mocks at
> > https://mozilla.invisionapp.com/share/BXBFSCU6P#/screens/229252091_Customization
> 
> +1 - that layout would have addressed all my confusion. Nice \o/

OK, great. In that case, duping this to 1354145. That implements all of the mock (so no more blue field around the bubble), except adding the image in the empty panel, which is bug 1373016.

> P.S. where can I get the Piranha extension you show there?

I have no idea, I didn't make the mocks. Poke Aaron Benson or Bryan Bell in SF and/or on slack. :-)
No longer blocks: 1352693
Status: NEW → RESOLVED
Closed: 3 years ago
No longer depends on: 1354145
Resolution: --- → DUPLICATE
Whiteboard: [photon-structure]
Duplicate of bug: 1354145
You need to log in before you can comment on or make changes to this bug.