Layout artefacts when loading https://web.whatsapp.com/ until resize, re-focus or tab change

RESOLVED DUPLICATE of bug 1373479

Status

()

Core
Layout
RESOLVED DUPLICATE of bug 1373479
6 months ago
6 months ago

People

(Reporter: gerd.neumann, Unassigned)

Tracking

({regression})

56 Branch
regression
Points:
---

Firefox Tracking Flags

(thunderbird_esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56- fixed)

Details

Attachments

(2 attachments)

(Reporter)

Description

6 months ago
Created attachment 8879321 [details]
Auswahl_120.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:56.0) Gecko/20100101 Firefox/56.0
Build ID: 20170619100247

Steps to reproduce:

Go to https://web.whatsapp.com/ as being logged in


Actual results:

Around the outer edges of the content I see layout artefacts. I do not think these happened when I still used Dev Edition (I just recently move to Nightly)


Expected results:

FWIW, as soon as I go to another tab and then back to https://web.whatsapp.com/ – or change the window size; the focus changes – then these artefacts are gone. 

Happens always again be just pressing F5 to reload.
(Reporter)

Updated

6 months ago
Summary: Layout artefacts when loading https://web.whatsapp.com/as until resize, re-focus or tab change → Layout artefacts when loading https://web.whatsapp.com/ until resize, re-focus or tab change

Updated

6 months ago
Component: Untriaged → Layout
Product: Firefox → Core

Comment 1

6 months ago
Gerd, do you see these layout artifacts with the current release 54 too?
If not, it could be a regression in 56.

In that case, could you use the tool mozregression to narrow down a regression range.
See http://mozilla.github.io/mozregression/ for details.
Run the command "mozregression --good=54" then for each nightly build launched, make the test and enter if it's good or bad. After the run, paste here the final pushlog.
Flags: needinfo?(gerd.neumann)
Keywords: regressionwindow-wanted
(Reporter)

Comment 2

6 months ago
Loic, here you go:

22:30.15 INFO: Narrowed inbound regression window from [958d2a5d, 0ff83c9d] (3 revisions) to [958d2a5d, 7f894f79] (2 revisions) (~1 steps left)
22:30.15 INFO: Oh noes, no (more) inbound revisions :(
22:30.15 INFO: Last good revision: 958d2a5d10091401fd5e900e8e063d21940c137e
22:30.15 INFO: First bad revision: 7f894f791cdf170d788507d0eff30024ce699523
22:30.15 INFO: Pushlog:
https://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=958d2a5d10091401fd5e900e8e063d21940c137e&tochange=7f894f791cdf170d788507d0eff30024ce699523

22:31.10 INFO: Looks like the following bug has the changes which introduced the regression:
https://bugzilla.mozilla.org/show_bug.cgi?id=1370430


Let me know if you need anything more. (FWIW, I the layout breakage is around the outer spaces of https://web.whatsapp.com and this is only visible when the window width is bigger than say 1600px)
Flags: needinfo?(gerd.neumann)

Comment 3

6 months ago
There are these patches:
Matt Woodrow — Bug 1359709 - Scale visible region for preserve-3d layers correctly. r=thinker
Matt Woodrow — Bug 1359709 - Use the DOM-ordering parent frame when deciding if a frame combines its transform with ancestors. r=dbaron
Matt Woodrow — Bug 1361970 - Make PostProcessLayers occlusion culling work against the surface we will draw to rather than the parent layer. r=mstange

Matt, do you think your patches could have regressed this?
Status: UNCONFIRMED → NEW
Has Regression Range: --- → yes
Has STR: --- → yes
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox56: --- → affected
status-thunderbird_esr52: --- → unaffected
tracking-firefox56: --- → ?
Ever confirmed: true
Flags: needinfo?(matt.woodrow)
Keywords: regressionwindow-wanted → regression
This might be a dup of bug 1373335, do the builds from the try push there fix it?
Flags: needinfo?(matt.woodrow)
(Reporter)

Comment 5

6 months ago
I guess you mean https://treeherder.mozilla.org/#/jobs?repo=try&revision=bd8be33db1e07d8fcc2ebcb25b027bcc802fa6f0 (as said in comment no 8 of bug 1373335). Hmm, well, I could test it if I knew how ;) Just spent 10min to find a download link under this treeherder page... Searching the web I came up with http://ftp.mozilla.org/pub/firefox/try-builds/mwoodrow@mozilla.com-bd8be33db1e07d8fcc2ebcb25b027bcc802fa6f0/ but this only has win+mac builds and I am on Linux.

Loic, any hints or are there docs on running the builds from the try push?
Flags: needinfo?(epinal99-bugzilla2)
(Reporter)

Comment 6

6 months ago
Created attachment 8879905 [details]
2017-06-21 13_07_53-Mozregression-gui.png

I guess I was able to run the aforementioned try build with mozregression. See screenshot, I hope I picked the right build... With this build the bug is definitely still visible.

Hence, I'm re-NIing to Matt.
Flags: needinfo?(epinal99-bugzilla2) → needinfo?(matt.woodrow)
(Reporter)

Comment 7

6 months ago
As of 56.0a1 (2017-06-23) (64-bit) this seems to be fixed. My guess would be that this might have been a dup of Bug 1373479 which is also fixed as of today.
Flags: needinfo?(matt.woodrow)

Comment 8

6 months ago
Let's dupe it.
Status: NEW → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1373479
Fixed in 56 in the duplicate.
status-firefox56: affected → fixed
tracking-firefox56: ? → -
You need to log in before you can comment on or make changes to this bug.