Labels aren't highlighted after performing a search

VERIFIED FIXED in Firefox 56

Status

()

P1
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: hani.yacoub, Assigned: rickychien)

Tracking

(Blocks: 1 bug)

56 Branch
Firefox 56
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox56 verified)

Details

(Whiteboard: [photon-preference])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Created attachment 8879481 [details]
Label.png

[Affected versions]: 
Nightly 56.0a1

[Affected platforms]:
Platforms: Windows 10 x 64, Mac OS X 10.12 and Ubuntu 16.04 x64.

[Steps to reproduce]:
1. Launch Firefox, go to about:config and search for "browser.preferences.search" and set it value to true.
2. Go to "about:preferences".
3. Search for "Nightly" in the search field.

[Expected result]:
Nightly in "When Nightly starts" should be highlighted.

[Actual result]:
Nightly in "When Nightly starts" is not highlighted.

[Note]:
All labels can't be highlighted after performing a search in "about:preferences" page.
(Reporter)

Updated

2 years ago
Blocks: 1357285
Whiteboard: [photon-preference]
Hani,

I cannot reproduce this issue on my latest Nightly. Can you try latest Nightly build and verify again?

I suspect this issue has been fixed recently.

thank you
Flags: needinfo?(hani.yacoub)
(Reporter)

Comment 2

2 years ago
It's reproducible on this build Firefox Nightly 56.0a1(2017-06-19)(64-bit), I'll wait for the next build and I'll let you know.
Flags: needinfo?(hani.yacoub)
(Reporter)

Comment 3

2 years ago
It's also reproducible with Firefox Nightly 56.0a1 (2017-06-20)(64-bit) but only on Windows and Ubuntu. 
It's not reproducible on Mac OS X 10.12.
Flags: needinfo?(rchien)
Hmm...sounds interesting since it breaks on Windows and Linux.

Thanks for reporting this issue. We'll take a look.
Has STR: --- → yes
Flags: needinfo?(rchien) → qe-verify+
Whiteboard: [photon-preference] → [photon-preference][triage]
Priority: -- → P2
Whiteboard: [photon-preference][triage] → [photon-preference]
Assignee: nobody → rchien
Status: NEW → ASSIGNED
Priority: P2 → P1
QA Contact: hani.yacoub
Probably worthy to look at code touched by bug 1360500.
(In reply to Tim Guan-tin Chien [:timdream] (please needinfo) from comment #5)
> Probably worthy to look at code touched by bug 1360500.

Specifically, the color set by 

http://searchfox.org/mozilla-central/rev/714606a8145636d93b116943d3a65a6a49d2acf8/layout/generic/nsTextFrame.cpp#3851

when the function is called.
Note that this issue is also reproducible on macOS by setting `ui.key.menuAccessKey = 17` (Windows sets to 18, please see [1].)

After enabling menuAccessKey, all label and description elements will be added an additional span wrapping around the Accesskey text node. As a result, the search algorithm is unable to detect and highlight the proper text as expected.



[1] http://kb.mozillazine.org/Ui.key.generalAccessKey#Possible_values_and_their_effects
Comment hidden (mozreview-request)
Patch has been verified on macOS with setting `ui.key.menuAccessKey = 17` and Windows.

Comment 10

2 years ago
mozreview-review
Comment on attachment 8880711 [details]
Bug 1374588 - Labels aren't highlighted after performing a search

https://reviewboard.mozilla.org/r/152060/#review157536

Thanks!
Attachment #8880711 - Flags: review?(mconley) → review+

Comment 11

2 years ago
Pushed by rchien@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/743a610d7281
Labels aren't highlighted after performing a search r=mconley

Comment 12

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/743a610d7281
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
(Reporter)

Comment 13

2 years ago
Build ID: 20170627030209
User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:56.0) Gecko/20100101 Firefox/56.0

Verified as fixed on Firefox Nightly 56.0a1 on Windows 10 x 64 and Ubuntu 16.04 x64.
Status: RESOLVED → VERIFIED
status-firefox56: fixed → verified
You need to log in before you can comment on or make changes to this bug.