Crash in mozalloc_abort | NS_DebugBreak | mozilla::ipc::LogicError | mozilla::net::PCookieService::Transition

RESOLVED DUPLICATE of bug 1376009

Status

()

Core
Networking: Cookies
--
critical
RESOLVED DUPLICATE of bug 1376009
6 months ago
4 months ago

People

(Reporter: kanru, Assigned: Amy)

Tracking

({crash})

Trunk
Unspecified
Windows 10
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [necko-next], crash signature)

(Reporter)

Description

6 months ago
This bug was filed from the Socorro interface and is 
report bp-05b9e726-6530-499e-bf36-76aaf0170619.
=============================================================

Shutdown progress:

| Rank | Shutdown progress | Count | %       |
|------+-------------------+-------+---------|
|    1 | change            |    22 | 84.62 % |
|    2 | profile           |    22 | 84.62 % |
|    3 | teardown          |    21 | 80.77 % |
|    4 | shutdown          |     3 | 11.54 % |
|    5 | xpcom             |     3 | 11.54 % |
|    6 | before            |     1 | 3.85 %  |

It looks like CookieServiceChild can still be used during shutdown but the IPC connection is already closed.

Junior, could you take a look?
Flags: needinfo?(juhsu)
Amy, this is probably relevant for you work?
Flags: needinfo?(amchung)

Comment 2

6 months ago
Note that bug 1331680 still keep this sync SendGetCookieString under pref.
We still need to take care of this.
Assignee: nobody → juhsu
Flags: needinfo?(juhsu)
Whiteboard: [necko-active]

Comment 3

6 months ago
After discussion with Amy, this might make bug 1331680 rebased.
Wanna hand to Amy and let her handle in or after bug 1331680.
Assignee: juhsu → amchung
Flags: needinfo?(amchung)
Whiteboard: [necko-active] → [necko-next]

Comment 4

6 months ago
Theoretically this is not a new issue.  Originally the issue happens in the form of bug 1333160. After bug 1363659 landed, the issue happens in the form of this bug.
See Also: → bug 1333160, bug 1363659

Updated

6 months ago
See Also: → bug 1376009
(Assignee)

Updated

4 months ago
Status: NEW → RESOLVED
Last Resolved: 4 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1376009
You need to log in before you can comment on or make changes to this bug.