Closed Bug 1375004 Opened 2 years ago Closed 2 years ago

Storage permissions are not updated when removed from View Page Info

Categories

(Firefox :: Preferences, defect)

55 Branch
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 1348223

People

(Reporter: simona.marcu, Unassigned)

References

(Blocks 1 open bug)

Details

(Whiteboard: [storage-v1])

[Affected versions]:
- Nightly 56.0a1
 
[Affected platforms]:
- Ubuntu 16.04, Windows 10, Mac OS X 10.12.
 
[Steps to reproduce]:
1. Launch Firefox
2. Allow storage permissions for one site (use navigator.storage.persist().then(persisted => console.log(persisted)); to see the permissions prompt)
3. Right-click on the page and select View Page Info
4. In the Permissions section - for Store Data in Persistent Storage check the "Use Default" button
5. Navigate to about:preferences#privacy
6. In the Site Data section - click on Settings
 
[Expected result]:
- Step 6: In Settings - Site Data dialog, the status of the page from step 2 should not be persistent.
 
[Actual result]:
- Step 6: In Settings - Site Data dialog the status of the page from step 2 is persistent.
Whiteboard: [storage-v1][triage]
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Whiteboard: [storage-v1][triage] → [storage-v1]
Duplicate of bug: 1348223
You need to log in before you can comment on or make changes to this bug.