Dispatch fullscreen events to element first rather than dispatch to document directly

RESOLVED FIXED in Firefox 64

Status

()

P2
normal
RESOLVED FIXED
2 years ago
4 months ago

People

(Reporter: xidorn, Assigned: xidorn)

Tracking

(Blocks: 1 bug, {dev-doc-complete})

Trunk
mozilla64
dev-doc-complete
Points:
---
Dependency tree / graph
Bug Flags:
webcompat ?

Firefox Tracking Flags

(firefox64 fixed)

Details

(Whiteboard: [webcompat])

Attachments

(3 attachments)

(Assignee)

Description

2 years ago
WebKit/Blink currently dispatches fullscreen events to elements, which makes sense, and matches our initial proposal of Fullscreen API [1].

It was not implemented that way probably because the current Gecko approach is easier to implement.

The spec has been changed to dispatch those events to element, and fallback to document in cases at whatwg/fullscreen#90.


[1] https://wiki.mozilla.org/Gecko:FullScreenAPI#fullscreenchange_event
Priority: -- → P2
(Assignee)

Comment 1

2 years ago
This is indeed something we want to do before we unprefix fullscreen.
Blocks: 1269276
Flags: webcompat?
Whiteboard: [webcompat]
(Assignee)

Updated

a year ago
Blocks: 1436334
Xidorn, are you planning to do this soonish?  If not, I can probably steal it.
Flags: needinfo?(xidorn+moz)
(Assignee)

Comment 3

a year ago
No, I don't currently have a plan, so if you want to work on this, go ahead. Thanks!
Flags: needinfo?(xidorn+moz)
(Assignee)

Comment 4

7 months ago
I'm going to take this as Chrome is going to ship unprefixed Fullscreen API, and I think we should try shipping that as soon as possible as well.
Assignee: nobody → xidorn+moz
(Assignee)

Updated

7 months ago
Depends on: 1489376
(Assignee)

Updated

7 months ago
Depends on: 1489385
(Assignee)

Comment 7

7 months ago
Some steps in file_fullscreen-api.html are adjusted in order to test
the behavior that the event is correctly dispatched to the document
when element is disconnected.

Depends on D5415
Comment on attachment 9007749 [details]
Bug 1375319 part 1 - Make DispatchTrustedEvent able to dispatch composed event and have fullscreen events composed. r=smaug

Olli Pettay [:smaug] has approved the revision.
Attachment #9007749 - Flags: review+
Comment on attachment 9007750 [details]
Bug 1375319 part 2 - Use a global const for element to fullscreen in file_fullscreen-api test. r=smaug

Olli Pettay [:smaug] has approved the revision.
Attachment #9007750 - Flags: review+
(Assignee)

Updated

6 months ago
Blocks: 1188256
Comment on attachment 9007751 [details]
Bug 1375319 part 3 - Try dispatching fullscreen events to element first rather than document. r=smaug

Olli Pettay [:smaug] has approved the revision.
Attachment #9007751 - Flags: review+

Comment 12

6 months ago
Pushed by xquan@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/1ad49dc53686
part 1 - Make DispatchTrustedEvent able to dispatch composed event and have fullscreen events composed. r=smaug
https://hg.mozilla.org/integration/autoland/rev/8a57ee2c6b31
part 2 - Use a global const for element to fullscreen in file_fullscreen-api test. r=smaug
https://hg.mozilla.org/integration/autoland/rev/f11d81a58cde
part 3 - Try dispatching fullscreen events to element first rather than document. r=smaug

Comment 13

6 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/1ad49dc53686
https://hg.mozilla.org/mozilla-central/rev/8a57ee2c6b31
https://hg.mozilla.org/mozilla-central/rev/f11d81a58cde
Status: NEW → RESOLVED
Last Resolved: 6 months ago
status-firefox64: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla64
(Assignee)

Updated

6 months ago
Depends on: 1491192
(Assignee)

Updated

6 months ago
Keywords: dev-doc-needed

Updated

6 months ago
Depends on: 1491787
Added to Firefox 64 for developers.
Keywords: dev-doc-needed → dev-doc-complete

Updated

4 months ago
Duplicate of this bug: 1507443
You need to log in before you can comment on or make changes to this bug.