[Mach-O] support BP_GetSupportedMIMETypes so Quicktime will play MPEGs

VERIFIED FIXED in mozilla1.3alpha

Status

()

Core
Plug-ins
P3
normal
VERIFIED FIXED
16 years ago
15 years ago

People

(Reporter: Peter Lubczynski, Assigned: Peter Lubczynski)

Tracking

Trunk
mozilla1.3alpha
PowerPC
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PL2:P3])

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

16 years ago
This is an offshoot from bug 113464 where the extra entry points
BP_GetSupportedMIMETypes and NP_GetMIMEDescription started being supported on
Carbon builds for MPEGs to work with Quicktime. This bug is about porting those
changes to the Mach-O build (nsPluginsDirDarwin.cpp).

Updated

16 years ago
Priority: -- → P3
Target Milestone: --- → mozilla1.1beta

Updated

16 years ago
Depends on: 155256
Whiteboard: [PL2:P3]

Updated

16 years ago
Target Milestone: mozilla1.1beta → mozilla1.2beta
(Reporter)

Updated

16 years ago
Target Milestone: mozilla1.2beta → mozilla1.3alpha
(Reporter)

Comment 1

16 years ago
*** Bug 178422 has been marked as a duplicate of this bug. ***

Comment 2

16 years ago
We need this for chimera too. Anyone have a testcase?
(Reporter)

Comment 3

16 years ago
see about:plugins, QT only lists 30 mime types in Mach-O beginning with
video/quicktime but CFM lists 45 types beginning with application/sdp.

The code that does this in the CFM build is here:
http://lxr.mozilla.org/mozilla/source/modules/plugin/base/src/nsPluginsDirMac.cpp#256
(Reporter)

Updated

16 years ago
Status: NEW → ASSIGNED
Summary: support BP_GetSupportedMIMETypes on Mach-O builds → [Mach-O] support BP_GetSupportedMIMETypes so Quicktime will play MPEGs

Comment 4

16 years ago
Created attachment 106318 [details] [diff] [review]
Non functional Q&D first cut

I lifted the impl of GetPluginInfo() from nsPluginsDirMac.cpp and got it
compiling in nsPluginsDirDarwin.cpp but we're still not picking up the mime
types from the alternate entry point in the QT plugin.	I figured I go ahead
and post the patch in case it was a useful starting point.
(Reporter)

Comment 5

16 years ago
Created attachment 106375 [details] [diff] [review]
patch v.2 (to Chimera tree)

Here's the last patch but with the plugin version constant incremented to cause
us to re-scan all plugin on next launch. Which this patch I'm seeing the extra
mime types show up in about:plugins.

TODO:
- garbage text is showing up in the mime type fields in Apple's java plugin in
about:plugins 

TO TEST:
- turning off a mime type in the QT control panel gets refected in
about:plugins  (does plugin need to be stat'ed?)
(Reporter)

Updated

16 years ago
Attachment #106318 - Attachment is obsolete: true
(Reporter)

Comment 6

16 years ago
Comment on attachment 106375 [details] [diff] [review]
patch v.2 (to Chimera tree)

Changing the mime types in the QT control panel isn't going to take effect
because we don't query the plugin if the timestamp doesn't change.  This is the
same problem as is already described with 'plugger' on Linux in bug 125469 and
also happens on CFM.

Opend bug 181010 about the garbled text. It needs to be fixed on CFM too.

Those bugs shouldn't hold up at least getting MPEGS working.
Attachment #106375 - Flags: superreview?(beard)
Attachment #106375 - Flags: review?(sdagley)

Updated

16 years ago
Attachment #106375 - Flags: review?(sdagley) → review+

Comment 7

16 years ago
     printf("[loaded plugin %s]\n", path);
+    pLibrary = outLibrary;
     return NS_OK;

Please #ifdef DEBUG the printf.

The rest looks OK, but would be easier to read with a diff -w.
(Reporter)

Comment 8

16 years ago
Created attachment 106872 [details] [diff] [review]
patch v.2.1

updated patch
Attachment #106375 - Attachment is obsolete: true

Comment 9

16 years ago
Looks good to me. If beard doesn't get to the SR, I can do it.

Comment 10

16 years ago
Comment on attachment 106872 [details] [diff] [review]
patch v.2.1

No need to initialize rv here:

+	   nsresult rv = NS_ERROR_FAILURE;
+	   rv = ParsePluginMimeDescription(pfnGetMimeDesc(), info);

In fact, you might as well declare rv at the top level of this function, since
it already seems to have an nsresult code.
Attachment #106872 - Flags: superreview-

Comment 11

16 years ago
Comment on attachment 106872 [details] [diff] [review]
patch v.2.1

Other than that, sr=beard.
Attachment #106872 - Flags: superreview- → superreview+
(Reporter)

Comment 12

16 years ago
patch in trunk, marking FIXED.

Simon, can you check this into the Chimera tree?
Status: ASSIGNED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → FIXED

Comment 13

16 years ago
Will do.

Comment 14

15 years ago
I checked this patch into the Chimera branch.

Comment 15

15 years ago
Excellent.. Confirming video/mp4 is registered by the QT plugin and shows up in
the about:plugins window. Test case now shows the QT content.

http://bugzilla.mozilla.org/attachment.cgi?id=105206&action=view
Status: RESOLVED → VERIFIED

Updated

15 years ago
Attachment #106375 - Flags: superreview?(beard)
You need to log in before you can comment on or make changes to this bug.