[Chimera] <param> ignored in XHTML

VERIFIED FIXED

Status

Camino Graveyard
Plug-ins
VERIFIED FIXED
16 years ago
16 years ago

People

(Reporter: Niklas Dougherty, Assigned: Simon Fraser)

Tracking

({testcase})

Details

(URL)

Attachments

(4 attachments, 2 obsolete attachments)

341 bytes, text/html
Details
21.34 KB, video/quicktime
Details
44.16 KB, video/quicktime
Details
652 bytes, application/xhtml+xml
Details
(Reporter)

Description

16 years ago
Chimera 0.6.

Loading http://www.student.lu.se/~kin02ndo/qt/ should bring up four clickable
Quicktime poster movies, without controllers. They have no controllers defined
in the files themselves (neither poster nor href movies), yet Chimera brings
forth the controllers. Chimera also ignores the params, so they are not
clickable. Compare with Mozilla.
(Reporter)

Comment 1

16 years ago
http://www.student.lu.se/~kin02ndo/val2002/ has another movie (MPEG-4), and it
is ignored completely, only displaying the fallback image.

Comment 2

16 years ago
Confirmed using Chimera/2002110415 on 10.1.5.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

16 years ago
Yes, it see this too in Chimera. Creating a reduced test case from url.

Comment 4

16 years ago
Created attachment 105206 [details]
Reduced test case

Test case contains two object element which are nested. First object element
uses type="video/mp4" and child object uses type="image/jpg.

Comment 5

16 years ago
In Chimera 0.6, The first object isn't rendered because the type is recognized
but the child object element is rendered because of the MIME type specified. 

Comment 6

16 years ago
In Chimera, the about:plugins section doesn't show video/mp4 as a register MIME
type so that's why the QT plugin isn't intialized. Under Mozilla/NS, the
about:plugins section DOES should this MIME type for the QT plugin (video/mp4,
audio/mp4). That's why it the UR/testcase works for that browser. Thanks beppe
for pointing that out !
(Assignee)

Comment 7

16 years ago
The other issues maybe be scriptable plugin issues.

Comment 8

16 years ago
QT has extra mime types through the symbol NP_GetMIMEDescription. 
Assignee: bnesse → peterl

Comment 9

16 years ago
should this be on bug 147957?

Comment 10

16 years ago
Do you mean 147975 ? It's got my vote since this is a new feature of QT 6 to
support mpeg 4 content.

Comment 11

16 years ago
Mime types are missing because of bug 137535.

*** This bug has been marked as a duplicate of 137535 ***
Status: NEW → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 12

16 years ago
Ho...!

Quicktime _does_ load at http://www.student.lu.se/~kin02ndo/qt/ (the given URL)
but Chimera doesn't read and pass the params. Hence controllers that shouldn't
be, hence no action when clicking on the href poster movies.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 13

16 years ago
Controllers should no longer be visible in poster movies (they were actually
there in the poster movies), although this is not reflected in Chimera because
it doesn't refresh. It uses cached files, and I can't seem to empty the cache.
Actually, the cache is nowhere to be found. Not in Library/Caches (where things
really should be placed) or /Library/Caches, not in a Chimera prefs folder in
Library/Preferences, and not even in a dumb (à la Phoenix) .chimera directory.

Updating summary.
Summary: [Chimera] Quicktime objects defunct / params ignored → [Chimera] <param> ignored
(Assignee)

Comment 14

16 years ago
There's a buton to empty the Cache under the History tab of the Navigation prefs
(not a good place, I agree). You could also remove the cache from disk; it's in
your profile folder in ~/Library/Application Support/Chimera/Profiles....

You obfuscated the summary. Should this bug be reclosed as a dup of bug 137535?

Comment 15

16 years ago
I will need to further research this too. Looks like we have two problems:

1) We don't recognized Mp4 mime types (type="video/mp4") so it's ignored and not
pass to the plugin
See the reduced test case. 


2) With the movies on http://www.student.lu.se/~kin02ndo/qt/, their MIME types
are "video/quicktime" so they do get displayed since their MIME is registered by
the plugin. However, we don't pass any of the parameters in the OBJECT element.
We need a simple test case for that issue.

Reporter, can you please provide a simple HTML test case with only OBJECT element ?
(Reporter)

Comment 16

16 years ago
Created attachment 105474 [details]
href movie
(Reporter)

Comment 17

16 years ago
Created attachment 105475 [details]
movie
(Reporter)

Comment 18

16 years ago
Created attachment 105476 [details]
xhtml file

Some testing yielded that poster movies work as intended for HTML files, i.e.
that params are read and parsed. However, the URL in the bug report is an XHTML
document, and for such documents <param> is ignored. This should provide some
help.

The poster movie loads in this test case, but it is not clickable, i.e. does
not load the param-referred movie.
(Assignee)

Comment 19

16 years ago
Is that valid XHTML?
(Reporter)

Comment 20

16 years ago
Updating subject again.

The document being UTF-16 is here irrelevant. Just tested with ISO-8859-1.
Keywords: testcase
Summary: [Chimera] <param> ignored → [Chimera] <param> ignored in XHTML

Comment 21

16 years ago
Is this bug 133654?
(Reporter)

Comment 22

16 years ago
Created attachment 105478 [details]
valid xhtml

No, enclosing in a div. Original page is valid however:

http://validator.w3.org:8001/check?uri=http%3A%2F%2Fwww.student.lu.se%2F%7Ekin02ndo%2Fqt%2F


The document located at <URL:http://www.student.lu.se/~kin02ndo/qt/>  was
checked and found to be valid XHTML 1.1.
Attachment #105476 - Attachment is obsolete: true
(Reporter)

Comment 23

16 years ago
Yes, looks like bug 133654. Isn't Chimera past 1.0.1?
(Assignee)

Comment 24

16 years ago
The patch in bug 133654 is pretty small, ignoring formatted changes. We might be
able to migrate it to chimera.
Assignee: peterl → sfraser
Status: REOPENED → NEW
(Assignee)

Comment 25

16 years ago
Created attachment 105499 [details]
Fixed version of attachment

The previous attachment had some bad characters in it. If I strip those out,
things seem to work fine.
(Assignee)

Updated

16 years ago
Attachment #105478 - Attachment is obsolete: true
(Assignee)

Comment 26

16 years ago
I migrated the fix for bug 133654 onto the chimera branch (being careful not to
clobber the fix for bug 152334).
Status: NEW → RESOLVED
Last Resolved: 16 years ago16 years ago
Resolution: --- → FIXED

Comment 27

16 years ago
Marking verified since param element is recognized in XHTML document. URL in
Comment 2 and reduced test case in Comment 4 are still a separate issue since
it's related to 137535.

Comment 28

16 years ago
Verified
Status: RESOLVED → VERIFIED

Comment 29

16 years ago
Oops, using 2002-11-08-04 NB under 10.2.1
You need to log in before you can comment on or make changes to this bug.