Wrong strings displaying all across the app (Java-side)

RESOLVED FIXED in Firefox 56

Status

()

Firefox for Android
General
--
critical
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: Oana Horvath, Assigned: nalexander)

Tracking

(Blocks: 1 bug, {qablocker})

56 Branch
Firefox 56
All
Android
qablocker
Points:
---

Firefox Tracking Flags

(fennec+, firefox54 unaffected, firefox55 unaffected, firefox56+ fixed)

Details

Attachments

(1 attachment)

500.00 KB, text/plain
Details
(Reporter)

Description

5 months ago
Created attachment 8880273 [details]
Logs

Devices: 
-Samsung Galaxy S6 EDGE (Android 7.0)
-Huawei Honor 5X (Android 5.1.1);
Build: Nightly 56.0a1 (2017-06-22);

Steps to reproduce:
1. Go to about:firefox and update Nightly to the 2017-06-21 build.
2. Check the about:home panels titles.

Expected result:
The panels are: Top sites, Bookmarks & History.

Actual result:
The panels names have been replaced with: Logins, Clear data & a long string about private tabs.
(Reporter)

Comment 1

5 months ago
Also see: 
- History tab's: Recently closed, Synced devices, Clear history
- The Settings menu
Probably more strings are mixed up.
Severity: normal → critical
tracking-fennec: --- → ?
status-firefox56: --- → affected
Keywords: qablocker
QA Contact: oana.horvath

Comment 2

5 months ago
As a note and after further investigations:
A fresh install of the June 21st Nightly build will not trigger this issue. Only after an update from a previous version will break the headers, also in settings menu.
Duplicate of this bug: 1375420
Guys, can you help? This is pretty serious
Flags: needinfo?(snorp)
Flags: needinfo?(s.kaspari)
Based on the discussion in the Channel Meeting, this is a possible regression range: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=e1e4a481b7e88dce163b9cccc2fb72032023befa&tochange=edb7e1ddd9b61e2af2a75cfe5baa0f92a54a2716.

It looks as if on 6-21 there were 2 Android builds.

Comment 6

5 months ago
For the 6-21 release, I did clean installs with apks from Mozilla, Google Play Store, and apkmirror. This morning, Mozilla gave me the 6-22 update (which I allowed to update). After reading this bug report, I uninstalled and re-installed from 6-22 apk.
In all cases, I saw the same bug.

I'm using a Verizon Ellipsis 10 tablet, running Android 5.1, Verizon update level IR7_20C59.

I also have Firefox stable 54 and Firefox beta 55 installed, both from apkmirror arm (not arm64) apks.

Updated

5 months ago
Duplicate of this bug: 1375587

Updated

5 months ago
Duplicate of this bug: 1375519

Updated

5 months ago
Component: Awesomescreen → General
Hardware: ARM → All
Summary: about: home panels names are corrupted → Wrong strings displaying all across the app (Java-side)
This feels like fallout from bug 1372486 and/or bug 1355625, per https://mail.mozilla.org/pipermail/mobile-firefox-dev/2017-June/002270.html and https://mail.mozilla.org/pipermail/mobile-firefox-dev/2017-June/002271.html. cc:ing the assignee and reviewers for the former bug and prospectively blocking the latter bug, as Nick requested in that mobile-firefox-dev thread.
Blocks: 1355625
Tracking 56+ for this issue, as this is widespread thoughout the app.
tracking-firefox56: --- → +
Oh yeah, this is almost certainly me.  Jumping on it right now.
Duplicate of this bug: 1375597
(In reply to Nick Alexander :nalexander from comment #11)
> Oh yeah, this is almost certainly me.  Jumping on it right now.

Confirmed with a fresh Google Play install of 56.0a1 (2017-06-22).

We'll back out Bug 1355625 ASAP.
Backed out bug 1355625. Will merge around to integration branches in the next few hours.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
Duplicate of this bug: 1375618
Flags: needinfo?(snorp)
Flags: needinfo?(s.kaspari)

Updated

5 months ago
Duplicate of this bug: 1375731
Assignee: nobody → nalexander
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox56: affected → fixed
Target Milestone: --- → Firefox 56

Updated

5 months ago
tracking-fennec: ? → +
You need to log in before you can comment on or make changes to this bug.