Crash in LdrUnloadDll

RESOLVED FIXED in Firefox 56

Status

()

Core
General
--
critical
RESOLVED FIXED
11 months ago
10 months ago

People

(Reporter: aklotz, Assigned: dmajor)

Tracking

({crash})

Trunk
mozilla56
Unspecified
Windows
crash
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed)

Details

(crash signature)

(Reporter)

Description

11 months ago
This bug was filed from the Socorro interface and is 
report bp-b29e4894-3fb0-45f4-acc9-135f70170622.
=============================================================

CRT tearing down the blocklist's NtDllIntercept? We should probably leak this one.
(Reporter)

Updated

11 months ago
Flags: needinfo?(dmajor)
(Assignee)

Updated

11 months ago
Blocks: 1372375
(Assignee)

Comment 1

11 months ago
Odd mix here...

Reason facet
1 	EXCEPTION_ACCESS_VIOLATION_WRITE 	24 	43.64 %
2 	EXCEPTION_ACCESS_VIOLATION_READ 	19 	34.55 %
3 	EXCEPTION_ILLEGAL_INSTRUCTION 	7 	12.73 %
4 	EXCEPTION_PRIV_INSTRUCTION 	5 	9.09 %
(Assignee)

Comment 2

11 months ago
(100.0% in signature vs 07.54% overall) Module "plugin-container.exe" = true [138.46% vs 22.16% if startup_crash = null]

I guess we could just avoid these hooks for plugin-container, they're not necessary.
Flags: needinfo?(dmajor)
(Assignee)

Comment 3

11 months ago
It turns out the gecko profiler does run in plugin-container, so in general we would still need those hooks there. But since we're not aware of anyone actually using the profiler for plugin-container, we could turn it off by default and remove the hooks. Markus suggested creating a pref and making SendInitProfiler conditional on it in http://searchfox.org/mozilla-central/source/dom/plugins/ipc/PluginModuleParent.cpp#633.
(Assignee)

Comment 4

11 months ago
(In reply to David Major [:dmajor] from comment #3)
> It turns out the gecko profiler does run in plugin-container, so in general
> we would still need those hooks there. But since we're not aware of anyone
> actually using the profiler for plugin-container, we could turn it off by
> default and remove the hooks. Markus suggested creating a pref and making
> SendInitProfiler conditional on it in
> http://searchfox.org/mozilla-central/source/dom/plugins/ipc/
> PluginModuleParent.cpp#633.

Would you be okay with me just sticking a Preferences::GetBool one-liner here, or do I need to make this a more formal pref? I really don't expect anyone other than #flow inhabitants will ever use it, if at all.
Flags: needinfo?(benjamin)
(Assignee)

Comment 5

11 months ago
Nevermind; this is probably the same root cause as all the other update/exit bugs this week, and I'll need to fix things more generally.
Flags: needinfo?(benjamin)
(Assignee)

Updated

11 months ago
Depends on: 1378442
(Assignee)

Comment 6

11 months ago
I believe this should be fixed in build 20170706. Let's see what crash-stats says after a few days.
(Assignee)

Comment 7

10 months ago
(In reply to David Major [:dmajor] from comment #6)
> I believe this should be fixed in build 20170706. Let's see what crash-stats
> says after a few days.

Confirmed - no hits as of that date.
Status: NEW → RESOLVED
Last Resolved: 10 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla56
Assignee: nobody → dmajor
status-firefox54: --- → unaffected
status-firefox55: --- → unaffected
status-firefox56: --- → fixed
status-firefox-esr52: --- → unaffected
You need to log in before you can comment on or make changes to this bug.