[hamburger panel] Print menu item label should have ellipsis

RESOLVED FIXED in Firefox 56

Status

()

Firefox
Menus
P1
normal
RESOLVED FIXED
2 months ago
a month ago

People

(Reporter: dao, Assigned: Adolfo Jayme, Mentored)

Tracking

(Blocks: 1 bug, {good-first-bug})

Trunk
Firefox 56
good-first-bug
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox56 fixed)

Details

(Whiteboard: [reserve-photon-structure][lang=xul])

Attachments

(1 attachment)

(Reporter)

Description

2 months ago
This item doesn't immediately print the page and should therefore have an ellipsis.

Updated

2 months ago
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]

Updated

2 months ago
See Also: → bug 1028230

Updated

2 months ago
Flags: qe-verify?
Priority: -- → P3

Updated

2 months ago
Flags: qe-verify? → qe-verify+

Updated

2 months ago
QA Contact: gwimberly
(Reporter)

Comment 1

2 months ago
Why was this put in the reserve? Please don't tell me that it can ship as-is because it was designed this way. Is this another case of Mac specifics (e.g. no print preview) spilling over to other platforms?
Flags: needinfo?(gijskruitbosch+bugs)

Comment 2

2 months ago
(In reply to Dão Gottwald [::dao] from comment #1)
> Why was this put in the reserve? Please don't tell me that it can ship as-is
> because it was designed this way. Is this another case of Mac specifics
> (e.g. no print preview) spilling over to other platforms?

Because this isn't a regression - print in the hamburger panel already behaves this way and already doesn't have an ellipsis, also on Linux/Windows, and the presence or absence of the '...' isn't something that needs to block release anyway. It's just not as important as everything else we're having to do.
Flags: needinfo?(gijskruitbosch+bugs)
(Reporter)

Comment 3

2 months ago
This bug can be fixed by replacing &printButton.label; with &printCmd.label; in browser/components/customizableui/content/panelUI.inc.xul:

http://searchfox.org/mozilla-central/rev/a1aa8b434a59df1b7530fee1ae78f11befb5c5dc/browser/components/customizableui/content/panelUI.inc.xul#676
Mentor: dao+bmo@mozilla.com
Keywords: good-first-bug
Whiteboard: [reserve-photon-structure] → [reserve-photon-structure][lang=xul]
(Assignee)

Comment 4

a month ago
Created attachment 8883812 [details] [diff] [review]
Proposed patch

Attaching a patch. Sorry, I couldn’t make sense of MozReview.
(Reporter)

Comment 5

a month ago
Comment on attachment 8883812 [details] [diff] [review]
Proposed patch

Looks good. Thanks!

(In reply to Adolfo Jayme from comment #4)
> Created attachment 8883812 [details] [diff] [review]
> Proposed patch
> 
> Attaching a patch. Sorry, I couldn’t make sense of MozReview.

That's fine, afaik we're getting rid of MozReview anyway in favor of something else.
Attachment #8883812 - Flags: review+
(Reporter)

Updated

a month ago
Assignee: nobody → fitojb
Priority: P3 → P1

Comment 6

a month ago
Pushed by dgottwald@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/788774d77bab
Use ellipsis in hamburger menu’s Print command. r=dao

Updated

a month ago
Status: NEW → ASSIGNED

Comment 7

a month ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/788774d77bab
Status: ASSIGNED → RESOLVED
Last Resolved: a month ago
status-firefox56: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56

Updated

a month ago
Iteration: --- → 56.2 - Jul 10
You need to log in before you can comment on or make changes to this bug.