Browser is broken if SearchBar is removed

VERIFIED FIXED in Firefox 56

Status

()

Firefox
Toolbars and Customization
P1
normal
VERIFIED FIXED
6 months ago
4 months ago

People

(Reporter: Alice0775 White, Assigned: johannh)

Tracking

({regression})

56 Branch
Firefox 56
Unspecified
Windows 10
regression
Points:
---

Firefox Tracking Flags

(firefox-esr52 unaffected, firefox54 unaffected, firefox55 unaffected, firefox56 fixed, firefox57 verified)

Details

(Whiteboard: [photon-visual][p1])

(Reporter)

Description

6 months ago
Steps to reproduce:
1. Remove SearchBar from Toolbar and restart
2. Attempt to open Web Developer menu from Hamburger menu
   Attempt to open Customize from Hamburger menu
   Attempt to open Browser Console with Ctrl+Shigt+J


Actual Results:
step2:
The content of them is empty.
Browser console does not open.


Expected Results:
Web Developer menu should open properly
Customize tab should open properly
Browser console should open properly


Regression Window:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6b0f55d8a2d24606dff719d52a3e6598ce92664e&tochange=5c870a786e945197a770a308aeeececdff8bac18

Regressed by: Bug 1364896
Flags: needinfo?(jhofmann)
Flags: needinfo?(dao+bmo)
(Reporter)

Comment 1

6 months ago
Error in Browser console(start with -jsconsole):
TypeError: Argument 1 of Document.getAnonymousElementByAttribute is not an object.[Learn More]  browser.js:8234:19
(Assignee)

Comment 2

6 months ago
Argh... Will fix.
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
Flags: needinfo?(jhofmann)
Flags: needinfo?(dao+bmo)
(Assignee)

Comment 3

6 months ago
Only happens on Windows 10, fwiw.
Flags: qe-verify+
OS: Unspecified → Windows 10
Priority: -- → P1
Whiteboard: [photon-visual][p1]

Comment 4

6 months ago
Duplicate Ticket: https://bugzilla.mozilla.org/show_bug.cgi?id=1376455
(Assignee)

Updated

6 months ago
Duplicate of this bug: 1376455
I've backed out bug 1364896 and will respin nightlies shortly.
https://hg.mozilla.org/mozilla-central/rev/8f80d594c08d5c7a112e5d4b9eb44ffca717eb7b
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
status-firefox56: affected → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56

Updated

6 months ago
Iteration: --- → 56.2 - Jul 10
QA Contact: brindusa.tot
Duplicate of this bug: 1376442

Comment 8

4 months ago
Tested on Windows 10 x64 with FF Nightly 57.0a1(2017-08-09) using the steps from the description and I can't reproduce this issue. I will mark as verified fixed.
Status: RESOLVED → VERIFIED
status-firefox57: --- → verified
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.