The temporarily disabled state of the reload button should block mouse events without flickering

RESOLVED FIXED in Firefox 56

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: florian, Assigned: jaws)

Tracking

(Depends on 1 bug, Blocks 1 bug)

Trunk
Firefox 56
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox56 fixed)

Details

Attachments

(1 attachment)

Reporter

Description

2 years ago
Currently the reload button is disabled for 650ms right after it appears to prevent accidentally reloading a page when the users tried to stop loading a page that finished loading at the exact same time.
Comment hidden (mozreview-request)
Assignee: nobody → jaws
Status: NEW → ASSIGNED
Duplicate of this bug: 1371085
Reporter

Comment 4

2 years ago
Comment on attachment 8881920 [details]
Bug 1376893 - Don't display the disabled reload button with less opacity since it is only disabled temporarily and causes flickering in the UI.

Thanks for the patch! Looks reasonable to me, but I don't have time to review all the other existing CSS rules applying to #reload-button, so forwarding the request to Johann.
Attachment #8881920 - Flags: review?(florian) → review?(jhofmann)
Comment hidden (mozreview-request)

Comment 6

2 years ago
mozreview-review
Comment on attachment 8881920 [details]
Bug 1376893 - Don't display the disabled reload button with less opacity since it is only disabled temporarily and causes flickering in the UI.

https://reviewboard.mozilla.org/r/152986/#review158712

Seems good now, thanks!
Attachment #8881920 - Flags: review?(jhofmann) → review+

Comment 7

2 years ago
Pushed by jwein@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/8a71fc08867b
Don't display the disabled reload button with less opacity since it is only disabled temporarily and causes flickering in the UI. r=johannh

Comment 8

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/8a71fc08867b
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
Depends on: 1378313
Duplicate of this bug: 1368653
You need to log in before you can comment on or make changes to this bug.