newsgroup postings stored as draft will send under wrong account

VERIFIED WORKSFORME

Status

MailNews Core
Networking: NNTP
--
major
VERIFIED WORKSFORME
16 years ago
9 years ago

People

(Reporter: Patrick, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

(Blocks: 1 bug)

Trunk
x86
Windows XP
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [adt2], URL)

(Reporter)

Description

16 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:0.9.9+)
Gecko/20020415
BuildID:    2002041503

Couldn't find a bug ID for this one yet:
When using different e-mail accounts for day-to-day mail and subscribing to
newsgroups, a mess up exists when a newsgroup message is composed but saved as
draft before posting.

It is composed using the account under which you subscribe to the newsgroup, but
saved as draft on LOCAL FOLDERS under your main account. 

When sending the stored message it is therefore send under the MAIN account
name, and not the one used to subscribe to the newsgroup

Reproducible: Always
Steps to Reproduce:
1.subscribe to a newsgroup message with something else than your REGULAR mail
account 
2.compose a newsgroup message
3.save the draft and close the compose window
4.the message is saved under LOCAL FOLDERS - DRAFTS
5.when opening (and sending) it will use your DEFAULT account as the sender, and
NOT the account you used to subscribe to the newsgroup.



Actual Results:  main e-mail account is specified as the sender of the post

Expected Results:  the e-mail account subscribed to the newsgroup should be the
sender

for me this is highly annoying because now my main account is listed in
newsgroups. This is bad because i write these postings on a personal title (can
lead to conflict of interest) and it is a cause of spam (privacy)

Comment 1

16 years ago
*** Bug 141519 has been marked as a duplicate of this bug. ***
Confirming.  I see this too with build 2002-05-17 on Windows 2000.
Status: UNCONFIRMED → NEW
Ever confirmed: true
*** Bug 150830 has been marked as a duplicate of this bug. ***

Comment 4

15 years ago
*** Bug 160549 has been marked as a duplicate of this bug. ***

Comment 5

15 years ago
This is really a duplicate of bug 59548...
nominating for next release
Keywords: nsbeta1

Comment 6

15 years ago
*** Bug 164881 has been marked as a duplicate of this bug. ***
Blocks: 176238

Comment 7

15 years ago
*** Bug 150525 has been marked as a duplicate of this bug. ***

Comment 8

15 years ago
*** Bug 165374 has been marked as a duplicate of this bug. ***

Comment 9

15 years ago
Bug 165374 had bug 59548 as BugsThisDependsOn. Adding depend in this bug.
(Reporter)

Comment 10

15 years ago
*** Bug 180369 has been marked as a duplicate of this bug. ***

Updated

15 years ago
Keywords: nsbeta1+

Updated

15 years ago
Keywords: nsbeta1

Comment 11

15 years ago
Mail triage team: nsbeta1+/adt2
Whiteboard: [adt2]
(Reporter)

Comment 12

15 years ago
*** Bug 194742 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 13

15 years ago
*** Bug 195716 has been marked as a duplicate of this bug. ***

Comment 14

15 years ago
WFM WinXP Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.3b) Gecko/20030210
(Reporter)

Comment 15

15 years ago
Don't know what [or who] fixed this, but problem does not appear anymore in
2003030204 on WinXP Pro SP1

Comment 16

15 years ago
changing to WFM based on my testing and comments from Patrick
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Comment 17

15 years ago
Branch build 2003-06-01: WinXP, ok.
Verified Worksforme based on previous comments and my testing.
Status: RESOLVED → VERIFIED
QA Contact: stephend → nbaca
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.