Advanced Layers breaks rendering on Google Maps

RESOLVED FIXED

Status

()

defect
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: dvander, Assigned: dvander)

Tracking

unspecified
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Screenshot is in bug 1375743. Pretty easy to reproduce by panning around.
This is a bug in texture coordinate flipping required for OpenGL textures, so it only manifests with WebGL.
Posted patch fixSplinter Review
I had copied texture coordinate flipping code from ImageHost, but ImageHost assumes the texture rect will always be (0, 0, 1, 1). Since AL uses a more precise region, we have to fully invert the y axis.
Attachment #8882619 - Flags: review?(matt.woodrow)
Attachment #8882619 - Flags: review?(matt.woodrow) → review+

Comment 3

2 years ago
Pushed by danderson@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/d4146ec1d551
Fix OpenGL texture coordinate flipping in Advanced Layers. (bug 1377303, r=mattwoodrow)
Posted patch reftestsSplinter Review
This takes an existing webgl reftest and just plops a div over it to reproduce the texture coordinate bug.
Attachment #8882647 - Flags: review?(matt.woodrow)
Whiteboard: keep-open
Attachment #8882647 - Flags: review?(matt.woodrow) → review+
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Whiteboard: keep-open
You need to log in before you can comment on or make changes to this bug.