Closed Bug 1377309 Opened 3 years ago Closed 3 years ago

Hamburger and page action menu jumps a pixel when opening a sub-panel like the library or 'send to devices' view

Categories

(Firefox :: Toolbars and Customization, defect)

defect
Not set
normal

Tracking

()

RESOLVED WORKSFORME

People

(Reporter: mossop, Unassigned)

References

(Blocks 1 open bug)

Details

Attachments

(1 file)

Attached video 2017-06-29 15-35-11.mp4
See the attached video, ideally zoomed and slowed down, and watch the lower left corner of the menu when the library view is opened the first time. It jumps maybe a pixel, maybe less. Just enough for me to notice.
Sorry, it's past midnight and I'm sleepy and this video is fullscreen and doesn't fit on my screen (mbp - I did use the a11y zoom to try and see the details, but still failed), so maybe (probably!) it's just me, but for my benefit, then: where am I looking? What's jumping? The contents of the panel, or the panel's outer bottom left corner/border? Is it at the end of the transition of the library view into view, or the beginning?
Flags: needinfo?(dtownsend)
See Also: → 1374509
Whiteboard: [photon-structure] → [photon-structure][triage]
(In reply to :Gijs from comment #1)
> Sorry, it's past midnight and I'm sleepy and this video is fullscreen and
> doesn't fit on my screen (mbp - I did use the a11y zoom to try and see the
> details, but still failed), so maybe (probably!) it's just me, but for my
> benefit, then: where am I looking? What's jumping? The contents of the
> panel, or the panel's outer bottom left corner/border? Is it at the end of
> the transition of the library view into view, or the beginning?

Right at the beginning of the library view transition the panel's outer border jumps. I find it easier to spot when looking at the bottom left corner where it moves to the right a tiny amount.
Flags: needinfo?(dtownsend)
Summary: Hamburger menu jumps a pixel when opening a sub-panel like the library view → Hamburger and page action menu jumps a pixel when opening a sub-panel like the library or 'send to devices' view
Duplicate of this bug: 1378116
Flags: qe-verify+
Priority: -- → P3
QA Contact: gwimberly
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Priority: P3 → P4
Dave, can you still see this with current nightly? There've been a number of tweaks to the panel behaviour since this got filed.
Flags: needinfo?(dtownsend)
I think this is fixed.
Status: NEW → RESOLVED
Closed: 3 years ago
Flags: needinfo?(dtownsend)
Resolution: --- → WORKSFORME
Flags: qe-verify+
Priority: P4 → --
QA Contact: gwimberly
Whiteboard: [reserve-photon-structure]
You need to log in before you can comment on or make changes to this bug.