Panel jiggles / twitches sideways when opening subpanel (in overflow / page action panels)

VERIFIED FIXED

Status

()

Firefox
Toolbars and Customization
P1
normal
VERIFIED FIXED
8 months ago
5 months ago

People

(Reporter: mstange, Assigned: mikedeboer)

Tracking

(Blocks: 1 bug)

Trunk
All
Mac OS X
Points:
---
Dependency tree / graph
Bug Flags:
qe-verify +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [photon-structure])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

8 months ago
Created attachment 8879394 [details]
jank helper

Steps to reproduce:
 1. Click on the three dots button in the URL bar.
 2. Click on "Send to device...".

During the subview transition, the whole panel jiggles horizontally a little.

Sometimes it even jerks about 100px to the left for a brief time.


This effect is easier to spot if the parent process is a little janky. You can create such a janky environment artificially by opening a new non-e10s window and loading the "jank helper" attachment into it. (But remember to close that window again afterwards, because it's going to eat your battery.)

Comment 1

8 months ago
Can you provide a screencast, and is this an up-to-date nightly? There were several changes in recent bugs ( bug 1370580, among other ones) that fixed this for me.
Flags: needinfo?(mstange)
Whiteboard: [photon] → [photon-structure][triage]
(Reporter)

Comment 2

8 months ago
Created attachment 8880033 [details]
screen recording

This seems to still affect the 2017-06-21 nightly.

Here's a screen recording. I followed these steps:
 1. Restart nightly.
 2. Open a new non-e10s window with File -> New Non-e10s Window
 3. Load attachment 8879394 [details] in that non-e10s window.
 4. Focus an existing e10s window (this step is probably not necessary).
 4. Click the three dots button.
 5. Click Send to Device...
Flags: needinfo?(mstange)

Updated

8 months ago
Flags: qe-verify?
Priority: -- → P2
Whiteboard: [photon-structure][triage] → [photon-structure]

Comment 3

8 months ago
Created attachment 8881220 [details]
jerking-panel.ogg

Thanks! Converted this to ogg/theora so it works in-browser.

On the video I see 3 things. 1 is bug 1374224 - the icons load after the menu opens, which is unfortunate. More generally, because the icons don't have a size set, they cause the text to shift when they do load.

The other 2 are:
first, the panel becomes narrower because we seem to hide the main view

second, then it becomes wider again because we seem to temporarily show both the new view and the old one (which gets painted without text somehow - no idea how that is even possible, I didn't think it would be). The bizarre part is that we seem to show the new view to the left of the old one, which doesn't make a lot of sense.
Attachment #8880033 - Attachment is obsolete: true

Updated

8 months ago
Flags: qe-verify? → qe-verify+

Updated

8 months ago
QA Contact: gwimberly

Updated

8 months ago
See Also: → bug 1377309

Updated

7 months ago
Blocks: 1380021

Updated

7 months ago
Summary: Panel jiggles / twitches sideways when clicking on "Send to device..." → Panel jiggles / twitches sideways when opening subpanel (in library / overflow / other panels)

Updated

7 months ago
Duplicate of this bug: 1386839

Comment 5

6 months ago
I think this is a side-effect from the CSS overflow properties not being set the same way as for the main hamburger panel. My patch in bug 1374315 seems to improve things. Contrary to my earlier change to the summary, I don't see any reports of this issue affecting the library panel when opened directly (ie not from within the overflow/hamburger panel), so I think it's just restricted to the page action and overflow panels which didn't/don't have a 'photon' attribute and therefore weren't getting the same overflow:hidden / overflow:visible applied to various bits of the panel, leading to some of the jumping in the screencast. 

The one thing that I'd like to double-triple-check before closing this post-1374315 is that after this is fixed, the resizing of the panel (ie there's a step in the video where the panel's current view seems to disappear) is also fixed.
Summary: Panel jiggles / twitches sideways when opening subpanel (in library / overflow / other panels) → Panel jiggles / twitches sideways when opening subpanel (in overflow / page action panels)

Updated

6 months ago
Assignee: nobody → mdeboer
Status: NEW → ASSIGNED
Iteration: --- → 57.3 - Sep 19
Priority: P2 → P1
(Assignee)

Updated

6 months ago
Depends on: 1374749
(Assignee)

Comment 6

5 months ago
Markus, we've got a new type of animation that doesn't use a xul:stack anymore... With it, I can't reproduce the behavior. Can you?
Status: ASSIGNED → RESOLVED
Last Resolved: 5 months ago
Flags: needinfo?(mstange)
Resolution: --- → FIXED
(Reporter)

Comment 7

5 months ago
I can't reproduce it either. Thanks!
Flags: needinfo?(mstange)
(Assignee)

Updated

5 months ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.