bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

JSON Viewer show Unicode replacement character instead of Cyrillic character 'н'

RESOLVED FIXED

Status

DevTools
JSON Viewer
RESOLVED FIXED
a year ago
a month ago

People

(Reporter: mavladi, Unassigned)

Tracking

54 Branch

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

a year ago
Created attachment 8883407 [details]
httpvinnitsavoted_oporaua_org_votes_events.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170630112252

Steps to reproduce:

Go to URL http://vinnitsavoted.oporaua.org/votes_events, and Firefox open JSON responce in the internal JSON Viewer



Actual results:

This responce has a JSON array in which 9th (counted from 0) item looks like:

"Результати поіменного голосування 16 сесії 7 скликан\ufffdя.pdf" -- in the "JSON" tab of the viewer

"Результати поіменного голосування 16 сесії 7 скликан�я.pdf"  -- in the "Raw data" tab of the viewer


Expected results:

Correct item looks like:
"Результати поіменного голосування 16 сесії 7 скликання.pdf", so that 52nd (counted from 0) character of this item must looks just like previous (while checking source code of the JSON responce page, it looks correct).
Component: Untriaged → Developer Tools: JSON Viewer
Fixed by bug 1367894, which will land on Firefox 55. Not sure why the U+FFFD appeared at random places (reloading your link can change where they appear). The old stream converter did things that didn't make much sense to me, I got rid of them and now your JSON seems to work properly.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Depends on: 1367894
Resolution: --- → FIXED

Updated

a month ago
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.