Open Bug 1378237 Opened 2 years ago Updated 7 months ago

ability to reset fonts to defaults

Categories

(Thunderbird :: Preferences, defect)

52 Branch
defect
Not set

Tracking

(Not tracked)

REOPENED

People

(Reporter: najoll, Unassigned)

References

Details

User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:54.0) Gecko/20100101 Firefox/54.0
Build ID: 20170628075643

Steps to reproduce:

I visited http://kb.mozillazine.org/Default_HTML_font_for_new_messages_-_Thunderbird.


Actual results:

I found myself more, rather than less, confused about Thunderbird settings. Even the heading styles on that page are confusing. (Ah, so a large-ish bold heading is a subheading of the unbolded headings . .) Please consider introducing a clearer system of distinguishing headings from subheadings.

Moreover, I was worried by the references to very early Thunderbird versions. 


Expected results:

How fonts work in Thunderbird should have been made clear to me, in a fairly painless fashion.

In particular, I am still hazy about the meaning of the 'fonts for' options that are filed under Tools -> Options -> Display -> Advanced - > Fonts and Encodings. 

Also, it would be nice were that an option to reset those 'fonts for' options to their defaults. What are those defaults, please?
Thanks for the report. MozillaZine is independent from Mozilla and as such issues with their Knowledge Base are not tracked here. Assuming your consent, I've copy-pasted you post to the respective MZ forum at http://forums.mozillazine.org/viewtopic.php?f=11&t=2825891&p=14754847#p14754847 to get it the right attention.

> Also, it would be nice were that an option to reset those 'fonts for' options to their defaults.

I'll leave this open in case someone wants to retarget this bug to the part of resetting fonts to their default (I see bug 259856 for Firefox and bug 953805 for Instantbird).
> Also, it would be nice were that an option to reset those 'fonts for' options to their defaults. What are those defaults, please?
As rsx11m indicated, this is bug 259856. 

I don't see the default values listed anywhere. But you can reset them by going to  Tools -> Options -> Advanced -> General -> Config Editor   Then plug in "font." and sort on the "status" column, then reset the values that show "user set".

> In particular, I am still hazy about the meaning of the 'fonts for' options that are filed under Tools -> Options -> Display -> Advanced - > Fonts and Encodings. 

Best to ask in support forum https://support.mozilla.org/en-US/products/thunderbird
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Component: Untriaged → Preferences
Resolution: --- → DUPLICATE
Duplicate of bug: 259856
(In reply to Wayne Mery (:wsmwk, NI for questions) from comment #2)
> As rsx11m indicated, this is bug 259856. 

Yes, but that's for Firefox. Thunderbird has its own implementation of the font-selection dialog in mail/components/preferences/fonts.{xul,js} thus won't automatically pick a fix up from Firefox.

Or not?
Flags: needinfo?(vseerror)
indeed
Status: RESOLVED → REOPENED
Ever confirmed: true
Flags: needinfo?(vseerror)
Resolution: DUPLICATE → ---
See Also: → 259856
Summary: The webpage explaining fonts is confusing and may well be very out of date → ability to reset fonts to defaults
See Also: → 601339
You need to log in before you can comment on or make changes to this bug.