Closed Bug 1378819 Opened 3 years ago Closed 2 years ago

Combined stop/reload button not working when the button is in the overflow panel

Categories

(Firefox :: Toolbars and Customization, defect, P1)

55 Branch
defect

Tracking

()

VERIFIED FIXED
Firefox 58
Tracking Status
firefox57 --- verified
firefox58 --- verified

People

(Reporter: Gijs, Assigned: Gijs)

References

Details

(Whiteboard: [reserve-photon-structure])

Attachments

(1 file)

This needs bug 1363485 to be fixed before you can reproduce.


STR:

1. right click stop/reload button
2. click 'pin to overflow panel'
3. restart firefox
4. open a page that takes a long time to load
5. open the overflow panel

ER:
button shows 'stop'

AR:
button shows 'reload'

It's not super clear to me off-hand why this is broken, but perhaps the fact that entering and leaving customize mode calls the uninit/init methods of the button is a clue.
Whiteboard: [photon-structure][triage]
Flags: qe-verify+
Priority: -- → P3
QA Contact: gwimberly
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Priority: P3 → P4
See Also: → 1401943
Assignee: nobody → gijskruitbosch+bugs
Priority: P4 → P1
Status: NEW → ASSIGNED
Comment on attachment 8911121 [details]
Bug 1378819 - fix combined stop/reload button not working in the overflow menu,

https://reviewboard.mozilla.org/r/182618/#review187954
Attachment #8911121 - Flags: review?(jaws) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/d9b87e369bdb
fix combined stop/reload button not working in the overflow menu, r=jaws
https://hg.mozilla.org/mozilla-central/rev/d9b87e369bdb
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 58
Comment on attachment 8911121 [details]
Bug 1378819 - fix combined stop/reload button not working in the overflow menu,

Approval Request Comment
[Feature/Bug causing the regression]: moving the reload/stop button to its own button
[User impact if declined]: reload/stop button stops working in some circumstances (not limited to the button being in the overflow panel)
[Is this code covered by automated tests?]: some basic ones, but clearly not ones that check this usecase...
[Has the fix been verified in Nightly?]: not yet
[Needs manual test from QE? If yes, steps to reproduce]: see comment 0
[List of other uplifts needed for the feature/fix]: n/a
[Is the change risky?]: not very
[Why is the change risky/not risky?]: relatively small patch, frontend-only, loooots of beta still to go.
[String changes made/needed]: nope
Attachment #8911121 - Flags: approval-mozilla-beta?
Comment on attachment 8911121 [details]
Bug 1378819 - fix combined stop/reload button not working in the overflow menu,

Fix a bug with the reload/stop button in some context. Taking it.
Should be in 47b4 (gtb tomorrow)
Attachment #8911121 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0
Build ID: 20170927100120

This issue has been verified on latest Firefox Nightly Build ID: 20170927100120 on Windows 8.1 x64, Mac OS 10.12 and Ubuntu 14.04 and it's not reproducible. When the page is loading the combined Stop/Reload button from Overflow menu shows the Stop state.
Status: RESOLVED → VERIFIED
I have reproduced the issue mentioned in comment 0, using an affected Firefox 57.0a1 build (BuildId:20170920220431).

I have verified that the issue is not reproducible using Firefox 57.0b7 (Build Id:20171009192146) on Windows 10 64bit, macOS 10.11.6 and Ubuntu 16.04 64bit.
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.