stylo: site issue: tab crash [@ nsCSSFrameConstructor::FindFrameForContentSibling ] on youtube.com

RESOLVED FIXED

Status

()

Core
CSS Parsing and Computation
P1
normal
RESOLVED FIXED
18 days ago
2 days ago

People

(Reporter: Darkspirit, Unassigned)

Tracking

(Blocks: 1 bug, {nightly-community})

Trunk
x86_64
Linux
nightly-community
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature, URL)

Attachments

(2 attachments)

(Reporter)

Description

18 days ago
Nightly 56 x64 20170706130309 @ Debian Testing (Linux 4.9.0-3-amd64, Radeon RX480)

I am unsure if this is a stylo bug,
but it happend while watching https://www.youtube.com/watch?v=PdGSBeZPoRo
and I saw mozilla::ServoRestyleManager::DoProcessPendingRestyles
in bp-21c9f7ab-867a-4dfc-b0e5-8d7aa0170706.

At this time I also had
gfx.webrender.enabled;true
gfx.webrendest.enabled;false
but resetted them after the tab crash. Later I got bug 1379018.

I don't know if this might be relevant, but I am testing extensions.webextensions.remote;true since today (bug 1357487 comment 4).
(Reporter)

Updated

18 days ago
Blocks: 1375906
Has STR: --- → no
Keywords: nightly-community
See Also: → bug 1379018
(Reporter)

Comment 1

18 days ago
No it can also happen without webrender+webrendest+OOPwebextensions.
bp-0c523c28-e1ca-4ec7-807d-0c4f30170706.

I should try this with a clean profile tomorrow. Or with that debug build from bug 1378064 comment 6 where I learned how to get RUST_LOG=debug.
(Reporter)

Comment 2

18 days ago
Created attachment 8884120 [details]
Screenshot_20170707_014519.png

This happend between the two reported crash signatures: the red video progress bar is missing. I can't reproduce this.
(Reporter)

Comment 3

18 days ago
Created attachment 8884122 [details]
Screenshot_20170707_014527.png

Then I wanted to leave fullscreen and ended like that. I switched to another tab, came back, got the e10s loading circle and then I closed the whole browser.
After starting Nightly again, I found bp-b890844a-8440-41e6-97f6-246720170706 [@ IPCError-browser | ShutDownKill ] on about:crashes.

This seems a bit like bug 137806 vice versa and bug 1377739.
(Reporter)

Comment 4

18 days ago
correction:
> This seems a bit like bug 1378064 [...]
(Reporter)

Updated

17 days ago
Crash Signature: [@ nsCSSFrameConstructor::FindFrameForContentSibling ]
I see APZ from the stack. This may be related to bug 1371450 as well I guess.
Priority: -- → P1
(Reporter)

Updated

12 days ago
See Also: → bug 1379624
(Reporter)

Comment 6

4 days ago
Last crash with Build 20170716100258 so far.
Sure, let's close this.
Status: NEW → RESOLVED
Last Resolved: 2 days ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.