Turn on OOP extensions by default on Linux

VERIFIED FIXED in Firefox 63

Status

P2
normal
VERIFIED FIXED
2 years ago
3 months ago

People

(Reporter: kmag, Assigned: kmag)

Tracking

(Depends on: 1 bug, Blocks: 3 bugs, {perf})

unspecified
mozilla63
Dependency tree / graph

Firefox Tracking Flags

(relnote-firefox 63+, firefox63+ fixed)

Details

(Whiteboard: triaged[qf:p3])

Attachments

(1 attachment)

Comment hidden (empty)
(Assignee)

Updated

2 years ago
webextensions: --- → ?

Comment 1

2 years ago
waiting if jim is getting to popover stuff
Priority: -- → P2
Whiteboard: triaged

Comment 2

2 years ago
Marking as quantum flow p1 because this is about the ability to run webextensions in a seperate process.
Whiteboard: triaged → triaged[qf:p1]

Comment 3

2 years ago
I went through the Quantum Flow release criteria and I don't believe Linux is a blocker for that. So taking off the :p1 designation.
Whiteboard: triaged[qf:p1] → triaged[qf]
Whiteboard: triaged[qf] → triaged[qf:p3]
Nightly 56 x64 20170706100310 @ Debian Testing (Linux 4.9.0-3-amd64, Radeon RX480)
extensions.webextensions.remote;true works now (I have stylo enabled), but panels have fat black (webrender:red) borders, which is okay for testing
dom.ipc.processCount.extension;2 does not work, no addons are loaded then, I will wait patiently
Duplicate of this bug: 1381810

Updated

2 years ago
status-firefox57: --- → wontfix

Updated

2 years ago
Depends on: 1406533
There is a problem with OOP Webextensions inside locationbar if the otherwise perfectly working GPU Process is enabled (for example for having some more stability while testing WebRender).
This might not be a blocker for this bug because the GPU Process is currently disabled by default on Linux.
See Also: → bug 1406230

Updated

11 months ago
Depends on: 1444595
No longer depends on: 1444595
Blocks: 1272869
Blocks: 1459560
(Assignee)

Updated

10 months ago
Duplicate of this bug: 1457477
Duplicate of this bug: 1462388

Updated

9 months ago
Product: Toolkit → WebExtensions

Updated

8 months ago
status-firefox57: wontfix → ---
(Assignee)

Updated

8 months ago
Duplicate of this bug: 1477454
Comment hidden (mozreview-request)

Comment 11

8 months ago
mozreview-review
Comment on attachment 8994917 [details]
Bug 1357487: Enable OOP extensions by default on all platforms.

https://reviewboard.mozilla.org/r/259428/#review266550

hooray!
Attachment #8994917 - Flags: review?(aswan) → review+
Backed out changeset e5423d29aaf0 (Bug 1357487) for reftest failures in file:///Z:/task_1532567375/build/tests/reftest/tests/layout/reftests/css-blending/blend-difference-stacking.html on a CLOSED TREE

Failure: https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&filter-resultStatus=testfailed&filter-resultStatus=busted&filter-resultStatus=exception&filter-classifiedState=unclassified&fromchange=4e08eb5f94e73e34f331f8dce08f77e9953d525a&selectedJob=190152821
Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=190152821&repo=mozilla-inbound&lineNumber=38618

01:37:09    ERROR -  REFTEST TEST-UNEXPECTED-FAIL | file:///Z:/task_1532567375/build/tests/reftest/tests/layout/reftests/css-blending/blend-difference-stacking.html == file:///Z:/task_1532567375/build/tests/reftest/tests/layout/reftests/css-blending/blend-difference-stacking-ref.html | image comparison, max difference: 221, number of differing pixels: 2
Flags: needinfo?(kmaglione+bmo)

Comment 14

8 months ago
Backout by shindli@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/95039d4a54ce
Backed out changeset e5423d29aaf0 for reftest failures in file:///Z:/task_1532567375/build/tests/reftest/tests/layout/reftests/css-blending/blend-difference-stacking.html on a CLOSED TREE
Sorry,
This is the correct failure for which this bug was backed out - https://treeherder.mozilla.org/#/jobs?repo=mozilla-inbound&fromchange=4e08eb5f94e73e34f331f8dce08f77e9953d525a&selectedJob=190146187

Failure log: https://treeherder.mozilla.org/logviewer.html#?job_id=190146187&repo=mozilla-inbound&lineNumber=2200


17:41:59     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_preload.js | Test timed out - 
17:41:59     INFO - Not taking screenshot here: see the one that was previously logged
17:41:59     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_preload.js | no tasks awaiting on messages - Got ["tabTitle"], expected []
17:41:59     INFO - Stack trace:
17:41:59     INFO - chrome://mochikit/content/browser-test.js:test_is:1305
17:41:59     INFO - chrome://mochikit/content/tests/SimpleTest/ExtensionTestUtils.js:ExtensionTestUtils.loadExtension/<:31
17:41:59     INFO - chrome://mochikit/content/browser-test.js:nextTest:705
17:41:59     INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1200
17:41:59     INFO - setTimeout handler*chrome://mochikit/content/browser-test.js:Tester_execTest:1162
17:41:59     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:996
17:41:59     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
17:41:59     INFO - Not taking screenshot here: see the one that was previously logged
17:41:59     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_preload.js | Extension left running at test shutdown - 
17:41:59     INFO - Stack trace:
17:41:59     INFO - chrome://mochikit/content/tests/SimpleTest/ExtensionTestUtils.js:ExtensionTestUtils.loadExtension/<:109
17:41:59     INFO - chrome://mochikit/content/browser-test.js:nextTest:705
17:41:59     INFO - chrome://mochikit/content/browser-test.js:timeoutFn:1200
17:41:59     INFO - setTimeout handler*chrome://mochikit/content/browser-test.js:Tester_execTest:1162
17:41:59     INFO - chrome://mochikit/content/browser-test.js:nextTest/<:996
17:41:59     INFO - chrome://mochikit/content/tests/SimpleTest/SimpleTest.js:SimpleTest.waitForFocus/waitForFocusInner/focusedOrLoaded/<:795
17:41:59     INFO - GECKO(1969) | MEMORY STAT | vsize 4559MB | residentFast 514MB | heapAllocated 116MB
17:41:59     INFO - TEST-OK | browser/components/extensions/test/browser/browser_ext_browserAction_popup_preload.js | took 45073ms
17:41:59     INFO - checking window state
17:41:59     INFO - Not taking screenshot here: see the one that was previously logged
17:41:59     INFO - TEST-UNEXPECTED-FAIL | browser/components/extensions/test/browser/browser_ext_browserAction_popup_preload.js | Found a browser window after previous test timed out -
Depends on: 1478661

Comment 17

8 months ago
awesomebugherder
https://hg.mozilla.org/mozilla-central/rev/ef1550969466
Status: NEW → RESOLVED
Last Resolved: 8 months ago
status-firefox63: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla63
We mentioned that change in 61 release notes for macOS, therefore I'll add a note in 63 nightly notes with the same wording:

WebExtensions now run in their own process on Linux
tracking-firefox63: --- → +
relnote-firefox: --- → 63+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
status-firefox63: fixed → ?
Note about this feature disabled from nightly 63 release notes following the backout.

Comment 22

8 months ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/cb97b513e80e
Status: REOPENED → RESOLVED
Last Resolved: 8 months ago8 months ago
status-firefox63: ? → fixed
Resolution: --- → FIXED
(Assignee)

Updated

8 months ago
Flags: needinfo?(kmaglione+bmo)

Comment 23

8 months ago
BTW enabling extensions.webextensions.remote also disabled Firefox' JSON viewer on the manifest.json. I doubt this is intended.

See bug 1481012 for a related issue/problem with the JSON viewer for WebExtensions.

Comment 24

7 months ago
Verified using Ubuntu 18.04 and FF Nightly running on latest build as of (04/08/2018). As the feature has also been validated previously, will be closing out this bug as well.

Updated

7 months ago
Status: RESOLVED → VERIFIED

Updated

3 months ago
Blocks: 1512818
You need to log in before you can comment on or make changes to this bug.