add core::option::expect_failed to the skip list

RESOLVED FIXED

Status

Socorro
General
RESOLVED FIXED
5 months ago
5 months ago

People

(Reporter: jcristau, Assigned: jcristau)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

5 months ago
This seems to be basically like assert in rust, so the signature should include the caller to not have all asserts lumped up (e.g. right now we have "alloc::oom::default_oom_handler | core::option::expect_failed").
(Assignee)

Comment 1

5 months ago
Created attachment 8884200 [details] [review]
github PR
I think we can skip all Rust functions in `std::panicking::.*` and `core::panicking::.*`.

Also, I think we should skip `core::str::slice_error_fail` from this Rust crash report: bp-2abff06f-d969-4ba5-845b-a98410170708.

Comment 3

5 months ago
(In reply to Chris Peterson [:cpeterson] from comment #2)
> I think we can skip all Rust functions in `std::panicking::.*` and
> `core::panicking::.*`.
> 
> Also, I think we should skip `core::str::slice_error_fail` from this Rust
> crash report: bp-2abff06f-d969-4ba5-845b-a98410170708.

I'd argue that panicking::.* could go on the ignore-list (irrelevant_signature_re.txt) since they're really just common boilerplate, while slice_error_fail could go on the prefix-list (prefix_signature_re.txt) since it at least provides some information about the nature of the failure.

Comment 4

5 months ago
> I'd argue that panicking::.* could go on the ignore-list

Oh hey, they're already there, nevermind. :-)
https://github.com/mozilla-services/socorro/blob/master/socorro/siglists/irrelevant_signature_re.txt#L12
(Assignee)

Comment 5

5 months ago
PR updated to add core::str::slice_error_fail

Comment 6

5 months ago
Commit pushed to master at https://github.com/mozilla-services/socorro

https://github.com/mozilla-services/socorro/commit/827e6b1941847141dedcda133421510b6e853471
Fixes bug 1379089 - add a couple of rust functions to the skip list (#3843)

* Fixes bug 1379089 - add core::option::expect_failed to the skip list

* Bug 1379089 - add core::str::slice_error_fail to the skip list

Updated

5 months ago
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → FIXED
This deployed to stage and I reprocessed this crash. 2abff06f-d969-4ba5-845b-a98410170708#tab-details

The signature went from:

    core::str::slice_error_fail

to:

    core::str::slice_error_fail | style::gecko::media_queries::Expression::parse


We'll push that to prod either today or tomorrow.
Duplicate of this bug: 1382547
You need to log in before you can comment on or make changes to this bug.