make crash signatures include stack frame past very common rust unwrapping functions

RESOLVED DUPLICATE of bug 1379089

Status

RESOLVED DUPLICATE of bug 1379089
a year ago
a year ago

People

(Reporter: heycam, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
I just submitted this crash report:

  https://crash-stats.mozilla.com/report/index/a7e19942-83cf-49f6-9249-15b9a0170720

and its signature is:

  [@ mozalloc_abort | abort | core::option::expect_failed ]

which I think is less helpful than it could be, since calling expect (and similar other functions like unwrap) is pretty common, and it would be useful to know what code was calling the unwrap/expect.

Would just dropping the "abort" if "mozalloc_abort" is in there too help?
This bug should be fixed by bug 1379089, which added `core::option::expect_failed` and `core::str::slice_error_fail` to the Socorro function skip list. That fix just landed today, so it will probably take 1-2 days before it hits the Socorro production server.

If there are other Rust functions we should skip, you can file issues on the Socorro GitHub repo:

https://github.com/mozilla-services/socorro/tree/master/socorro/siglists
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1379089
The fix for bug #1379089 got pushed to -prod just now.
You need to log in before you can comment on or make changes to this bug.