Closed Bug 1379123 Opened 2 years ago Closed 2 years ago

Sort UI density options by density

Categories

(Firefox :: Toolbars and Customization, defect, P1)

defect

Tracking

()

VERIFIED FIXED
Firefox 56
Iteration:
56.3 - Jul 24
Tracking Status
firefox56 --- fixed
firefox57 --- verified

People

(Reporter: dao, Assigned: johannh)

References

Details

(Whiteboard: [photon-visual][p4])

Attachments

(1 file)

Current order of options is Normal, Compact, Touch. I think Compact, Normal, Touch would make more sense.
Aaron, any opinion/preference about this?
Flags: needinfo?(abenson)
(In reply to Dão Gottwald [::dao] from comment #0)
> Current order of options is Normal, Compact, Touch. I think Compact, Normal,
> Touch would make more sense.

Is that from top to bottom? I like the suggestion but I wonder if we should sort by "size" by placing the larger option at the top:

Touch
Normal
Compact
Flags: needinfo?(abenson)
Flags: qe-verify+
Priority: -- → P2
QA Contact: brindusa.tot
Whiteboard: [photon-visual][triage] → [photon-visual]
Whiteboard: [photon-visual] → [photon-visual][p4]
Assignee: nobody → jhofmann
Status: NEW → ASSIGNED
I think Dão's suggestion makes more sense, because the Tablet Mode checkbox works well when it's below the Touch mode menuitem. https://mozilla.invisionapp.com/share/ENBBK0F9U#/screens/229252105

Do you agree, Aaron?
Flags: needinfo?(abenson)
Comment on attachment 8886149 [details]
Bug 1379123 - Sort UI density options by density.

https://reviewboard.mozilla.org/r/156948/#review162046
Iteration: 56.3 - Jul 24 → ---
Attachment #8886149 - Flags: review?(dao+bmo) → review+
Priority: P1 → P2
Iteration: --- → 56.3 - Jul 24
Priority: P2 → P1
Iteration: --- → 56.3 - Jul 24
Priority: P2 → P1
Ah, that's a fair point. I can get behind that! (Compact, Normal, Touch)
Flags: needinfo?(abenson)
Pushed by jhofmann@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/30aea103f6b4
Sort UI density options by density. r=dao
https://hg.mozilla.org/mozilla-central/rev/30aea103f6b4
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 56
QA Contact: brindusa.tot → ovidiu.boca
I verified this issue on Windows 10 and Windows 7 and Windows 10 on Surface Pro 2 with the latest Nightly 57.0a1(2017-08-16) and I can confirm the fix, the current order is Compact, Normal, Touch.
Status: RESOLVED → VERIFIED
Flags: qe-verify+
You need to log in before you can comment on or make changes to this bug.