Closed Bug 1380021 Opened 2 years ago Closed 2 years ago

Tests for showing the Page Action device sub-menu have a 5 second waits in them

Categories

(Firefox :: Toolbars and Customization, defect, P1)

56 Branch
defect

Tracking

()

RESOLVED FIXED
Firefox 57
Iteration:
57.3 - Sep 19
Tracking Status
firefox-esr52 --- unaffected
firefox55 --- unaffected
firefox56 --- wontfix
firefox57 --- fixed

People

(Reporter: standard8, Assigned: adw)

References

Details

(Keywords: regression, Whiteboard: [reserve-photon-structure])

Attachments

(1 file)

In moving some code in bug 1380009, we discovered that bug 1369095 added a 5 second timeout to parts of tests that are waiting for the device sub-menu to be displayed:

http://searchfox.org/mozilla-central/rev/5dadcbe55b4ddd1e448c06c77390ff6483aa009b/browser/base/content/test/urlbar/browser_page_action_menu.js#436

(as of bug 1380009 landing, that is moving to the head.js file).

If I run the tests manually (MacBook Pro mid-2015), I can see that occasionally the device sub-menu is opened and then after a second or so it changes size, before the test then continues.

This seems like it is could be a glitch that users will see, hence flagging as possible photon work.
I think the glitching is basically bug 1374509. The 5 seconds isn't when the relayout happens that you noticed here:

(In reply to Mark Banner (:standard8) from comment #0)
> If I run the tests manually (MacBook Pro mid-2015), I can see that
> occasionally the device sub-menu is opened and then after a second or so it
> changes size, before the test then continues.

the timeout is related to when the item populates because of delayed sync initialization on startup and ensuring that's finished (for which apparently there isn't a useful event).
Depends on: 1374509
Flags: qe-verify-
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
Priority: -- → P4
Drew is fixing this in bug 1384464, I believe.
Depends on: 1384464
Bug 1384464 fixed browser_page_action_menu.js (let's hope it sticks and actually works), but browser_PageActions.js still has a 5000ms timeout: https://dxr.mozilla.org/mozilla-central/rev/ffe6cc09ccf38cca6f0e727837bbc6cb722d1e71/browser/modules/test/browser/browser_PageActions.js#1031

I think that's the only other one that needs fixing.
Assignee: nobody → adw
Status: NEW → ASSIGNED
Iteration: --- → 57.3 - Sep 19
Priority: P4 → P1
A bunch of en-US failures... not sure what that's about.  Bad tree I guess.  But other than that, try looks OK.
Attachment #8910052 - Flags: review?(gijskruitbosch+bugs)
Comment on attachment 8910052 [details]
Bug 1380021 - Remove 5000ms timeout from browser_PageActions.js test.

https://reviewboard.mozilla.org/r/181526/#review187024
Attachment #8910052 - Flags: review?(gijskruitbosch+bugs) → review+
Pushed by gijskruitbosch@gmail.com:
https://hg.mozilla.org/integration/autoland/rev/c613a3d09cc1
Remove 5000ms timeout from browser_PageActions.js test. r=Gijs
https://hg.mozilla.org/mozilla-central/rev/c613a3d09cc1
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 57
Version: unspecified → 56 Branch
You need to log in before you can comment on or make changes to this bug.