Closed Bug 1380465 Opened 3 years ago Closed 2 years ago

Investigate browser_windowopen_reflows.js failures on Linux and re-enable by default

Categories

(Firefox :: General, enhancement, P2)

enhancement

Tracking

()

RESOLVED FIXED
Firefox 59
Tracking Status
firefox59 --- fixed

People

(Reporter: mconley, Assigned: hiro)

References

Details

(Keywords: intermittent-failure)

Attachments

(3 files)

In bug 1363361, I disabled browser_windowopen_reflows.js because of intermittent failure in the debug case, and perma-failure in the opt case. Clearly there's some kind of race going on here.

We should figure this out and re-enable the test.
Priority: -- → P2
I did take a look this.  It seems to me, as of today, the expected reflows for Linux is not correct.

Since bug 1414252, we haven't observed the reflow caused by handleEvent@chrome://browser/content/tabbrowser.xml, we can drop it.

Also after bug 1377447, we use EnsurePresShellInitAndFrames for focus handling, so in theory, we should not observe a reflow caused by focusAndSelectUrlBar@chrome://browser/content/browser.js.  I don't quite understand why other platforms still observe the reflow though.

A try, looks good so far.
https://treeherder.mozilla.org/#/jobs?repo=try&revision=2e81e39c4443d2e39bb08f21ea150d85145a426b
Comment on attachment 8937631 [details]
Bug 1380465 - Drop an expected reflow for Linux in browser_windowopen_reflows.js.

https://reviewboard.mozilla.org/r/208308/#review214190

Thanks!

::: commit-message-7c457:1
(Diff revision 1)
> +Bug 1380465 - Drop an expected reflow for Linux as well. r?mconley

Nit: "as well" suggests that this is a continuation of something, but it's the first patch in a series. Perhaps let's have this be:

"Bug 1380465 - Drop an expected reflow for Linux in browser_windowopen_reflows.js. r?mconley"

::: commit-message-7c457:3
(Diff revision 1)
> +Bug 1380465 - Drop an expected reflow for Linux as well. r?mconley
> +
> +The reflow has suppressed by bug 1414252, and the expected reflow

Nit: "has" -> "was"
Attachment #8937631 - Flags: review?(mconley) → review+
Comment on attachment 8937632 [details]
Bug 1380465 - Drop the expected reflows about focus on url bar.

https://reviewboard.mozilla.org/r/208310/#review214196

Thanks!
Attachment #8937632 - Flags: review?(mconley) → review+
Comment on attachment 8937633 [details]
Bug 1380465 - Enable browser_windowopen_reflows.js on Linux.

https://reviewboard.mozilla.org/r/208312/#review214198

I really appreciate you turning this back on, hiro!
Attachment #8937633 - Flags: review?(mconley) → review+
Duplicate of this bug: 1425833
(In reply to Mike Conley (:mconley) (:⚙️) - Backlogged on reviews and needinfos from comment #6)
> Comment on attachment 8937631 [details]
> Bug 1380465 - Drop an expected reflow for Linux in
> browser_windowopen_reflows.js.
> 
> https://reviewboard.mozilla.org/r/208308/#review214190
> 
> Thanks!
> 
> ::: commit-message-7c457:1
> (Diff revision 1)
> > +Bug 1380465 - Drop an expected reflow for Linux as well. r?mconley
> 
> Nit: "as well" suggests that this is a continuation of something, but it's
> the first patch in a series.

That's really good to know for me. :)  Thanks!
Assignee: nobody → hikezoe
Status: NEW → ASSIGNED
Pushed by hikezoe@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e7e988f26a6d
Drop an expected reflow for Linux in browser_windowopen_reflows.js. r=mconley
https://hg.mozilla.org/integration/autoland/rev/5619db8e95f7
Drop the expected reflows about focus on url bar. r=mconley
https://hg.mozilla.org/integration/autoland/rev/fc7d77434051
Enable browser_windowopen_reflows.js on Linux. r=mconley
https://hg.mozilla.org/mozilla-central/rev/e7e988f26a6d
https://hg.mozilla.org/mozilla-central/rev/5619db8e95f7
https://hg.mozilla.org/mozilla-central/rev/fc7d77434051
Status: ASSIGNED → RESOLVED
Closed: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 59
You need to log in before you can comment on or make changes to this bug.