Closed Bug 1380969 Opened 2 years ago Closed 2 years ago

3.57 - 4.03% sessionrestore_no_auto_restore (linux64) regression on push 62987053a39486946f3ccf76336857f63371936a (Thu Jul 13 2017)

Categories

(Firefox :: Session Restore, defect)

defect
Not set

Tracking

()

RESOLVED WONTFIX

People

(Reporter: igoldan, Unassigned)

References

(Blocks 1 open bug)

Details

(Keywords: perf, regression, talos-regression)

Talos has detected a Firefox performance regression from push:

https://hg.mozilla.org/integration/autoland/pushloghtml?changeset=62987053a39486946f3ccf76336857f63371936a

As author of one of the patches included in that push, we need your help to address this regression.

Regressions:

  4%  sessionrestore_no_auto_restore linux64 pgo e10s     679.50 -> 706.92
  4%  sessionrestore_no_auto_restore linux64 opt e10s     799.88 -> 828.42

Improvements:

 26%  sessionrestore_many_windows windows10-64 opt e10s     4,296.48 -> 3,173.75
 19%  sessionrestore_many_windows windows7-32 opt e10s      4,069.31 -> 3,287.08
  8%  sessionrestore_many_windows linux64 opt e10s          2,364.75 -> 2,168.92


You can find links to graphs and comparison views for each of the above tests at: https://treeherder.mozilla.org/perf.html#/alerts?id=7934

On the page above you can see an alert for each affected platform as well as a link to a graph showing the history of scores for this test. There is also a link to a treeherder page showing the Talos jobs in a pushlog format.

To learn more about the regressing test(s), please see: https://wiki.mozilla.org/Buildbot/Talos/Tests

For information on reproducing and debugging the regression, either on try or locally, see: https://wiki.mozilla.org/Buildbot/Talos/Running

*** Please let us know your plans within 3 business days, or the offending patch(es) will be backed out! ***

Our wiki page outlines the common responses and expectations: https://wiki.mozilla.org/Buildbot/Talos/RegressionBugsHandling
:beekill Were you expecting the no_auto_restore regressions? I'm just asking to be sure.
Anyway, I guess this bug will be a WONTFIX, as it is a Talos update.
Flags: needinfo?(nnn_bikiu0707)
Yeah, I tested the patch and it does increase the time a little bit. I think this should be a WONTFIX.
Flags: needinfo?(nnn_bikiu0707)
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.