The onboarding tour notifications and tour dialog close buttons should have a tooltip

VERIFIED FIXED in Firefox 56

Status

()

defect
P3
normal
VERIFIED FIXED
2 years ago
2 years ago

People

(Reporter: verdi, Assigned: Fischer)

Tracking

unspecified
Firefox 56
Points:
---
Bug Flags:
qe-verify +

Firefox Tracking Flags

(firefox56 verified, firefox58 verified)

Details

(Whiteboard: [photon-onboarding])

Attachments

(2 attachments)

(Reporter)

Description

2 years ago
Posted image tooltip.png
I inadvertently left out a tooltip to be shown on hover of the close button in the Firefox 56 tour notifications. It should read, "Don't show this again"
Whiteboard: [photon-onboarding] → [photon-onboarding][triage]
Flags: qe-verify+
Priority: P3 → P2
QA Contact: jwilliams
Whiteboard: [photon-onboarding][triage] → [photon-onboarding]
Target Milestone: --- → Firefox 56
(Assignee)

Updated

2 years ago
Assignee: nobody → fliu
Status: NEW → ASSIGNED
(Assignee)

Comment 1

2 years ago
(In reply to Verdi [:verdi] from comment #0)
> Created attachment 8886905 [details]
> tooltip.png
> 
> I inadvertently left out a tooltip to be shown on hover of the close button
> in the Firefox 56 tour notifications. It should read, "Don't show this again"
Hi Verdi,
Just afraid that "Don't show this again" may cause some confusion because the next notification for next tour would still be prompted after click it. Not sure if user would think why this notification is showing again. Let's have a discussion on the next con-call meeting.
Flags: needinfo?(mverdi)
Priority: P2 → P1
based on discussion happened in the weekly meeting with PM/UX, we should see user's feedback before making any further change on the existing design. change it to P3 and it will be revised in Fx57 nightly.
Assignee: fliu → nobody
Status: ASSIGNED → NEW
Priority: P1 → P3
Version: 53 Branch → unspecified
(Assignee)

Updated

2 years ago
Duplicate of this bug: 1377496
(Assignee)

Updated

2 years ago
Summary: Fx 56 tour notifications close button should have a tooltip → The onboarding tour notifications close button should have a tooltip
(Reporter)

Comment 4

2 years ago
(In reply to Fischer [:Fischer] from comment #1)
> (In reply to Verdi [:verdi] from comment #0)
> > Created attachment 8886905 [details]
> > tooltip.png
> > 
> > I inadvertently left out a tooltip to be shown on hover of the close button
> > in the Firefox 56 tour notifications. It should read, "Don't show this again"
> Hi Verdi,
> Just afraid that "Don't show this again" may cause some confusion because
> the next notification for next tour would still be prompted after click it.
> Not sure if user would think why this notification is showing again. Let's
> have a discussion on the next con-call meeting.

Michelle and I talked this over and decided we should use "Dismiss" instead.
Flags: needinfo?(mverdi)
Assignee: nobody → fliu
Status: NEW → ASSIGNED
Summary: The onboarding tour notifications close button should have a tooltip → The onboarding tour notifications and tour dialog close buttons should have a tooltip
(Assignee)

Comment 5

2 years ago
Per the bug 1377283 comment 3, the tour dialog close button's tooltip is "Close".

Comment 7

2 years ago
mozreview-review
Comment on attachment 8890693 [details]
Bug 1381366 - The onboarding tour notifications and tour dialog close buttons should have a tooltip,

https://reviewboard.mozilla.org/r/161878/#review167600
Attachment #8890693 - Flags: review?(dtownsend) → review+
(Assignee)

Updated

2 years ago
Keywords: checkin-needed

Comment 8

2 years ago
Pushed by cbook@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/e8d5f44ef5eb
The onboarding tour notifications and tour dialog close buttons should have a tooltip, r=mossop
Keywords: checkin-needed

Comment 9

2 years ago
bugherder
https://hg.mozilla.org/mozilla-central/rev/e8d5f44ef5eb
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
I can confirm that this is fixed.
Status: RESOLVED → VERIFIED
I have verified that the x on the notification has a tooltip on Win 10 x64, Win 7 x32, Ubuntu 16.04 x32, and Mac 10.12 with Firefox 58.
You need to log in before you can comment on or make changes to this bug.