Closed Bug 1381372 Opened 4 years ago Closed 4 years ago

Sync shouldn't restore removed bookmark/history items and default bookmark items

Categories

(Firefox :: Sync, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1332290

People

(Reporter: masayuki, Unassigned)

Details

I sync a lot of profiles in my environments. Most of them are created for only testing Firefox/Gecko. When I launch Firefox in such environment, all bookmarks and history items which are not in cloud are sent to cloud and then, my daily use profile receives them even if I removed them from bookmarks and history. (or duplicating default bookmark items a lot.)

I guess that this can cause sync engine checks only the difference between current profile and cloud. But I believe that if the item came from cloud or a default bookmark item, it shouldn't be sent back to cloud.

I really hope that each item should have its origin, created in the profile, came from cloud or default bookmark. And sync engine should send only the first type items to the cloud.
Bug 1177516 is about default bookmarks. However, I don't really understand what you are saying about normal bookmarks and history - the intent of Sync is to ensure all history and bookmarks are the same across all your devices - it is by design that when you connect a new device to Sync, all bookmarks and history from that device are stored on the server and downloaded by other devices.

We do have bug 1215415 on file to allow for data to be enabled or disabled per device (ie, so you could tell these profiles to never sync history or bookmarks) - is that maybe what you are after?

Could you please clarify what you are asking for here?
Flags: needinfo?(masayuki)
(In reply to Mark Hammond [:markh] from comment #1)
> Bug 1177516 is about default bookmarks. However, I don't really understand
> what you are saying about normal bookmarks and history - the intent of Sync
> is to ensure all history and bookmarks are the same across all your devices
> - it is by design that when you connect a new device to Sync, all bookmarks
> and history from that device are stored on the server and downloaded by
> other devices.

Yes, I didn't try to say that it is a bug.

I meant that for example,

1. Connect first device to a Firefox account and upload all data to the cloud.
2. Connect second device to the account and sync it (then, default bookmarks shouldn't be duplicated as bug 1177516).
3. Don't use the second device for a while (I usually don't use some profiles in VM for several months).
4. In the first device, delete some bookmarks and/or some items in history.
5. Sync it to the cloud.
6. Use the second device and sync it.

Then, I expect that removed items are also removed in the second device. Finally, they may be copied back to the first device via cloud. However, I'm not sure if you can actually reproduce with this STR because I cannot reproduce this bug with some profiles which are used almost everyday. As I said at #3, I sometimes reproduce when I sync my account with pretty old profile than daily use profile. I guess that the oldness is the cause of this bug.
Flags: needinfo?(masayuki)
Ah, thanks for the explanation. So this is actually a series of bugs. For background, deletions are stored on the server, but typically *not* retained on each device. However, in some cases and for various reasons, all server data can be lost (which is somewhat "by design" - it is expected other clients will re-upload all their data when this happens). However, when this does happen it's possible items can be "resurrected" as you have seen - and this also explains why you can't reproduce it now.

Bug 1332290 is a general bug for this (which will probably end up as a meta once we start addressing things), and bug 1343103 is for doing a better job here with bookmarks while bug 1214117 is for history - so thanks for reporting, but sadly these are all known issues which already have bugs, so I'm going to close this as a dupe (but please feel free to reopen if you think there's something here that isn't already covered, or I've missed something)
Status: NEW → RESOLVED
Closed: 4 years ago
Depends on: 735532, 1346850
Resolution: --- → DUPLICATE
Summary: Sync shouldn't restore removed bookmark/history items and default bookmark items → Store tombstones for history
Duplicate of bug: 1332290
oops, I didn't mean to make those other changes.
No longer depends on: 735532, 1346850
Summary: Store tombstones for history → Sync shouldn't restore removed bookmark/history items and default bookmark items
Thank you very much for introducing the bugs! I'm sorry for that I couldn't find the bugs before reporting.
You need to log in before you can comment on or make changes to this bug.