Closed Bug 1381416 Opened 2 years ago Closed 2 years ago

Stop using an iframe for the markup view

Categories

(DevTools :: General, enhancement, P2)

51 Branch
enhancement

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1242201

People

(Reporter: miker, Assigned: miker)

References

(Blocks 1 open bug)

Details

The markup view is currently 3 iframes deep into our developer tools. Each iframe needs to be created and then we need to wait for the iframe's contentDocument to be created before continuing. Obviously, doing this 3 times drastically slows down the inspector's loading time.

We should move the markup tool out of it's iframe... maybe using HTML imports?

Filter on EdgarMallory
Priority: -- → P2
Blocks: 1381428
No longer blocks: 1381418
No longer blocks: 1381428
Depends on: 1381428
Assignee: nobody → mratcliffe
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1242201
Product: Firefox → DevTools
You need to log in before you can comment on or make changes to this bug.