Arrow of overflow panel alignment with the rest of the panel in customize mode depends on font size (at least Linux, probably elsewhere too)

RESOLVED DUPLICATE of bug 1378277

Status

()

Firefox
Toolbars and Customization
RESOLVED DUPLICATE of bug 1378277
9 months ago
9 months ago

People

(Reporter: Towkir, Unassigned)

Tracking

56 Branch
Unspecified
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

9 months ago
Created attachment 8887904 [details]
arrohead-with-gap-at-bottom.png

[This is a linux only bug]
STR:
1. Open up a fresh nightly on a fresh profile
2. From the hamburger menu, choose customize or enter customize mode however you want.

AR:
There is a gap below the arrowhead and the content box. See screenshot.

ER:
The gap should not be there, this looks fine on windows though. Not sure about MacOS
(Reporter)

Updated

9 months ago
Whiteboard: [photon-visual]

Updated

9 months ago
Whiteboard: [photon-visual] → [photon-structure][triage]
Summary: Remove the gap between "panel-arrobox" and "panel-arrocontent" on "customization-panel-container" → Remove the gap between "panel-arrowbox" and "panel-arrowcontent" on "customization-panel-container"

Comment 1

9 months ago
I can't reproduce. What OS theme is this? GTK version? Linux flavour?
Flags: needinfo?(3ugzilla)
(Reporter)

Comment 2

9 months ago
Yes, Its Ubuntu 16.04, GTK, default firefox theme without any modifications or themes or addons.
Flags: needinfo?(3ugzilla)

Comment 3

9 months ago
(In reply to [:Towkir] Ahmed from comment #2)
> Yes, Its Ubuntu 16.04, GTK, default firefox theme without any modifications
> or themes or addons.

I asked about your OS theme - what gnome/gtk theme are you using?
Flags: needinfo?(3ugzilla)

Comment 4

9 months ago
Also what window manager is this? The thick borders around stuff make me suspect it's very different from whatever I'm running (which I *think* is the default gnome/unity thing)
(Reporter)

Comment 5

9 months ago
Created attachment 8887938 [details]
with-ambiance-theme.png

Oh, alright. The thick border was because of the Flatabulous[0] theme, but later on I changed to default ambiance theme. And here is the screenshot then.

[0] https://github.com/anmoljagetia/Flatabulous
Flags: needinfo?(3ugzilla)

Comment 6

9 months ago
(In reply to [:Towkir] Ahmed from comment #5)
> Created attachment 8887938 [details]
> with-ambiance-theme.png
> 
> Oh, alright. The thick border was because of the Flatabulous[0] theme, but
> later on I changed to default ambiance theme. And here is the screenshot
> then.
> 
> [0] https://github.com/anmoljagetia/Flatabulous

I still can't reproduce with ambiance. I even tried a separate user account and still can't reproduce. I installed Flatabulous, still can't reproduce. Is this really a clean profile, or is stylo turned on or something (there are clearly non-clean-profile things in that screenshot, like the additional custom button).

I expect it has to do with text size or something, if this happens on a clean profile. Can you inspect the arrow and log sizes in the bug?
Flags: needinfo?(3ugzilla)
(Reporter)

Comment 7

9 months ago
Created attachment 8887960 [details]
changing-fong-size.gif

I guess I found the reason behind this. I did change the default font size from 11 to 9 through unity-tweak-tool
See the gif as an evidence. But I am really confused why it should matter, or, if someone changes the font size and the design breaks like this.
Flags: needinfo?(3ugzilla)

Comment 8

9 months ago
(In reply to [:Towkir] Ahmed from comment #7)
> Created attachment 8887960 [details]
> changing-fong-size.gif
> 
> I guess I found the reason behind this. I did change the default font size
> from 11 to 9 through unity-tweak-tool
> See the gif as an evidence. But I am really confused why it should matter,
> or, if someone changes the font size and the design breaks like this.

Ahhh, this makes sense. Thanks for checking. I expect the fix required here and for bug 1378277 will be the same.
See Also: → bug 1378277
Summary: Remove the gap between "panel-arrowbox" and "panel-arrowcontent" on "customization-panel-container" → Arrow of overflow panel alignment with the rest of the panel in customize mode depends on font size (at least Linux, probably elsewhere too)
Whiteboard: [photon-structure][triage] → [reserve-photon-structure]
(Reporter)

Comment 9

9 months ago
Created attachment 8888264 [details]
font-size-matters.jpg

From windows, I changed my display settings from smaller (100%) to medium (125%)  in   Control Panel > Appearance and Personalization > Display   
which moved the arrow 1px down from where it should have been, my monitor is 1080px, so I zoomed the image before attaching here. With a closer look (just above the red line), it should be visible.

Comment 10

9 months ago
This turns out to just be the same as bug 1378277.
Status: NEW → RESOLVED
Last Resolved: 9 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1378277

Updated

9 months ago
Whiteboard: [reserve-photon-structure]
You need to log in before you can comment on or make changes to this bug.