bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox 55 tabs go blank when gnome-shell is restarted.

RESOLVED DUPLICATE of bug 1377950

Status

()

Core
Widget: Gtk
RESOLVED DUPLICATE of bug 1377950
a year ago
5 months ago

People

(Reporter: Hussam Al-Tayeb, Unassigned)

Tracking

(Blocks: 1 bug)

55 Branch
All
Linux
Points:
---

Firefox Tracking Flags

(firefox54 unaffected, firefox55- affected, firefox56- affected)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:55.0) Gecko/20100101 Firefox/55.0
Build ID: 20170721185346

Steps to reproduce:

In firefox 55 and 56, all tabs become blank when I alt-f2 ->r in Gnome-shell. This bug does not happen in firefox 54. I'm not using wayland.
On the same desktop stack, firefox 54 and 52 do not show this issue.
To reproduce:
1) install firefox 55 or above on gnome and open a few tabs.
2) press alt-f2 to bring up the run (enter a command) dialog.
3) type r and press enter.


Actual results:

gnome-shell is reexecuted (same PID).
firefox tabs are now blank.
firefox main process memory usage also dropped by ~30MB.

I am using NVIDIA graphics.
Just to be clear, downgrading to firefox 54 or 52 'fixes' the issue.
(Reporter)

Updated

a year ago
Component: Untriaged → Widget: Gtk
Product: Firefox → Core
(Reporter)

Updated

a year ago
Blocks: 635134
[Tracking Requested - why for this release]: regression that leaves Firefox in an unusable state 

 7:24.71 INFO: Last good revision: 6e9b45f7ed376eea83df779d60b3c4562b188a66
 7:24.71 INFO: First bad revision: 457e6aea4650b4cc8bbc6581342fdc44bc8dbec1
 7:24.71 INFO: Pushlog:
https://hg.mozilla.org/integration/autoland/pushloghtml?fromchange=6e9b45f7ed376eea83df779d60b3c4562b188a66&tochange=457e6aea4650b4cc8bbc6581342fdc44bc8dbec1
Status: UNCONFIRMED → NEW
status-firefox54: --- → unaffected
status-firefox55: --- → affected
status-firefox56: --- → affected
tracking-firefox55: --- → ?
tracking-firefox56: --- → ?
Ever confirmed: true
OS: Unspecified → Linux
Hardware: Unspecified → All

Comment 2

a year ago
Dupe of #1376451.  Glad to see someone else is able to confirm this behaviour.
Duplicate of this bug: 1376451
Looks like dupe of Bug 1377950
Status: NEW → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1377950
Not tracking here since this was marked as a duplicate.
tracking-firefox55: ? → -
tracking-firefox56: ? → -
You need to log in before you can comment on or make changes to this bug.