Windows ClearType Enhanced Contrast: 300 causes fatal error: "assert(0 <= c && c <= SK_Scalar1)"

RESOLVED DUPLICATE of bug 1383817

Status

()

defect
RESOLVED DUPLICATE of bug 1383817
2 years ago
2 years ago

People

(Reporter: infofrommozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

2 years ago
+++ This bug was initially created as a clone of Bug #1348584 +++

I get an assertion when starting a debug build on Windows 10.

| s:\Projects\mozi\comm-central\mozilla\gfx\skia\skia\src\core\SkScalerContext.h:76: fatal error: "assert(0 <= c && c <= SK_Scalar1)"
| Abort from sk_abort
| Hit MOZ_CRASH() at s:/Projects/mozi/comm-central/mozilla/memory/mozalloc/mozalloc_abort.cpp:33
| [GPU 8164] WARNING: Shutting down GPU process early due to a crash!: file s:/Projects/mozi/comm-central/mozilla/gfx/ipc/GPUParent.cpp, line 399

It's this in setContrast():

<https://dxr.mozilla.org/comm-central/source/mozilla/gfx/skia/skia/src/core/SkScalerContext.h#76>

This is a regression by attachment 8884339 [details] [diff] [review] of Bug 1376026

This call to: "params->GetEnhancedContrast()"
<https://dxr.mozilla.org/comm-central/source/mozilla/gfx/thebes/gfxDWriteFonts.cpp#718>

bypasses the fix of Bug #1348584
Reporter

Updated

2 years ago
Blocks: 1376026

Updated

2 years ago
Flags: needinfo?(mchang)
Flags: needinfo?(mchang) → needinfo?(lsalzman)
Status: UNCONFIRMED → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1383817
Flags: needinfo?(lsalzman)
You need to log in before you can comment on or make changes to this bug.