All users were logged out of Bugzilla on October 13th, 2018

[52esr] disabling FTP breaks build

RESOLVED DUPLICATE of bug 1391467

Status

RESOLVED DUPLICATE of bug 1391467
a year ago
8 months ago

People

(Reporter: enrico.weigelt, Unassigned)

Tracking

52 Branch

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

a year ago
User Agent: Mozilla/5.0 (X11; Linux i686 (x86_64)) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/58.0.3029.110 Chrome/58.0.3029.110 Safari/537.36

Steps to reproduce:

ac_add_options --enable-network-protocols=about,data,device,file,http,res,viewsource,wyciwyg

note: left off ftp (dont need/want it in mail client) 


Actual results:

 1:04.82   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/accessible/ipc/other/PDocAccessible.ipdl', line 7:
 1:04.83   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/ipc/glue/PFileDescriptorSet.ipdl', line 5:
 1:04.84   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/ipc/glue/PBackground.ipdl', line 6:
 1:04.84   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/dom/indexedDB/PBackgroundIDBFactory.ipdl', line 6:
 1:04.87   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/dom/indexedDB/PBackgroundIDBDatabase.ipdl', line 6:
 1:04.88   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/dom/indexedDB/PBackgroundIDBDatabaseRequest.ipdl', line 6:
 1:04.89   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/dom/filehandle/PBackgroundMutableFile.ipdl', line 5:
 1:04.89   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/dom/filehandle/PBackgroundFileHandle.ipdl', line 5:
 1:04.90   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/dom/filehandle/PBackgroundFileRequest.ipdl', line 6:
 1:04.90   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/dom/ipc/PBlob.ipdl', line 7:
 1:04.90   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/dom/ipc/PContent.ipdl', line 15:
 1:04.90   in file included from `/home/nekrad/src/thunderbird/comm-esr52/mozilla/security/manager/ssl/PPSMContentDownloader.ipdl', line 7:
 1:04.91 /home/nekrad/src/thunderbird/comm-esr52/mozilla/netwerk/ipc/PChannelDiverter.ipdl:7: error: can't locate include file `PFTPChannel.ipdl'



Expected results:

the other IDLs should not reference PFTPChannel if FTP is not activated (#ifdef missing ?)

Updated

a year ago
Component: Untriaged → Build Config

Comment 1

a year ago
That part of the build config is from Firefox, so you should move this bug to the Firefox queue and ask there.

Updated

a year ago
Component: Build Config → Build Config
Product: Thunderbird → Core
This option will be going away. Work tracked in bug 1391467.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1391467

Updated

8 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.